Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#49161 closed defect (worksforme)

valgrind: failed check for a supported compiler on 10.7

Reported by: mojca (Mojca Miklavec) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: someuser12, neverpanic (Clemens Lang)
Port: valgrind

Description

Configuration for valgrind fails on 10.7 (Xcode 4.6.3, Build version 4H1503, Apple LLVM version 4.2 (clang-425.0.28) (based on LLVM 3.2svn)):

:info:configure checking dependency style of /usr/bin/clang... gcc3
:info:configure checking for diff -u... yes
:info:configure checking for a supported version of gcc... no (4.2)
:info:configure configure: error: please use gcc >= 3.0 or clang >= 2.9 or icc >= 13.0

Attachments (1)

main.log (10.5 KB) - added by mojca (Mojca Miklavec) 5 years ago.

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by mojca (Mojca Miklavec)

Attachment: main.log added

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Port: valgrind added; raimue removed

comment:2 Changed 5 years ago by someuser12

Possible duplicate of #32994.

comment:3 Changed 5 years ago by someuser12

Cc: macosx12345@… added

Cc Me!

comment:4 Changed 5 years ago by mojca (Mojca Miklavec)

It might be related. But the weird fact is that I had valgrind installed already and it failed during an upgrade. The other ticket is 4 years old. (PS: If you want me to test the patch and provide feedback, I might only be able to do that in a very near future, I will upgrade to 10.11 very soon.)

comment:5 Changed 5 years ago by raimue (Rainer Müller)

Probably, gcc was already just a wrapper for llvm-gcc on OS X 10.7 Lion. A possible simple solution could be to just add the right compiler.blacklist statements.

If someone comes up with a patch, I am happy to apply it. Otherwise, I consider OS X 10.7 Lion unsupported. I won't investigate myself to fix this.

comment:6 Changed 5 years ago by mojca (Mojca Miklavec)

I'm willing to look into this (in the very near future, before I upgrade), but I need some guidelines as I have no clue what valgrind is trying to do in the first place and what compiler it requires.

Here's what my system says:

> gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.11.00)

but if it is trying to call gcc as such, it's probably not using the right compiler anyway.

Do you have any idea which compiler is expected/required?

comment:7 Changed 5 years ago by raimue (Rainer Müller)

I should have read the main.log more thoroughly, it is already using /usr/bin/clang and /usr/bin/clang++.

Looking at XcodeVersionInfo and the configure script, it seems to be checking --version for clang version X.Y, but that string no longer exists. So apparently, newer clang even on current systems only passes that check because -dumpversion always returns 4.2.1.

While this works at the moment, it is inaccurate. Although the whole check only wants to exclude gcc <= 3.x anyway.

comment:8 Changed 5 years ago by mojca (Mojca Miklavec)

So maybe we should just remove the check then?

comment:9 Changed 5 years ago by robertmhaas@…

I am also experiencing this problem, on MacOS X 10.8.5. I removed the configure check with "vim" to make it install.

comment:10 Changed 5 years ago by mojca (Mojca Miklavec)

Cc: cal@… added

This problem reminds me on #47035. (I'm not saying that the patch would be similar in any way, but the symptoms seem similar, with a different approach of upstream developers.)

comment:11 Changed 4 years ago by raimue (Rainer Müller)

Resolution: worksforme
Status: newclosed

I believe this has been fixed upstream.

comment:12 Changed 4 years ago by mojca (Mojca Miklavec)

Apparently not, a new ticket under #53525.

Note: See TracTickets for help on using tickets.