Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#4954 closed defect (worksforme)

BUG: dsniff fails to install on Tiger

Reported by: jherek@… Owned by: tobypeterson
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: nathan.stocks@…, ryan@…
Port:

Description

Fails to compile with tons of error messages in sshcrypto.c

Attachments (2)

dsniff (2.5 KB) - added by anita14@… 15 years ago.
port -d build dsniff
dsniff.debug (9.0 KB) - added by anita14@… 15 years ago.
port install -d dsniff

Download all attachments as: .zip

Change History (16)

comment:1 Changed 15 years ago by toby@…

In the future, please include the full output of 'port -d build dsniff'. In any case, looks like the OpenSSL port doesn't include blowfish.h for some reason.

comment:2 Changed 15 years ago by toby@…

Component: basedports

Changed 15 years ago by anita14@…

Attachment: dsniff added

port -d build dsniff

comment:3 Changed 15 years ago by ryan@…

A duplicate of Bug #4671?

comment:4 Changed 15 years ago by ryan@…

Cc: ryan@… added

comment:5 Changed 15 years ago by toby@…

Different error.

comment:6 Changed 15 years ago by ryan@…

OK. The debug output log attached here doesn't match Bug #4671, but the original description does, so I wasn't sure.

comment:7 Changed 15 years ago by toby@…

Status: newassigned

OK, it builds for me now. I'll need the output of a *clean* build. So, do this...

port clean dsniff port -d build dsniff

...and include the output in this bug. Thanks.

comment:8 Changed 15 years ago by toby@…

Owner: changed from darwinports-bugs@… to toby@…
Status: assignednew

comment:9 Changed 15 years ago by toby@…

Status: newassigned

comment:10 Changed 15 years ago by mww@…

Summary: dsniff fails to install on TigerBUG: dsniff fails to install on Tiger

Changed 15 years ago by anita14@…

Attachment: dsniff.debug added

port install -d dsniff

comment:11 Changed 15 years ago by anita14@…

Still won't build for me. Full debug added.

comment:12 Changed 15 years ago by toby@…

Can't reproduce this failure on any of my Tiger boxes...

comment:13 Changed 15 years ago by toby@…

Resolution: worksforme
Status: assignedclosed

comment:14 Changed 15 years ago by nathan.stocks@…

Cc: nathan.stocks@… added

Hmmm...doesn't work for me, either:

$ sudo port -v install dsniff (snip) ./arpspoof.c: In function 'arp_send': ./arpspoof.c:49: warning: passing argument 1 of 'libnet_get_hwaddr' from incompatible pointer type ./arpspoof.c:49: error: too many arguments to function 'libnet_get_hwaddr' ./arpspoof.c:58: warning: pointer targets in assignment differ in signedness ./arpspoof.c:60: warning: passing argument 6 of 'libnet_build_ethernet' from incompatible pointer type ./arpspoof.c:60: error: too few arguments to function 'libnet_build_ethernet' ./arpspoof.c:64: error: 'ETH_H' undeclared (first use in this function) ./arpspoof.c:64: error: (Each undeclared identifier is reported only once ./arpspoof.c:64: error: for each function it appears in.) ./arpspoof.c:64: error: too few arguments to function 'libnet_build_arp' ./arpspoof.c:67: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type ./arpspoof.c:71: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type ./arpspoof.c:77: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type ./arpspoof.c:80: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type ./arpspoof.c: In function 'arp_find': ./arpspoof.c:114: warning: passing argument 2 of 'arp_cache_lookup' from incompatible pointer type ./arpspoof.c: In function 'main': ./arpspoof.c:181: warning: assignment makes pointer from integer without a cast make: * [arpspoof.o] Error 1

Warning: the following items did not execute (for dsniff): com.apple.activate com.apple.build com.apple.destroot com.apple.archive com.apple.install Error: /opt/local/bin/port: Status 1 encountered during processing.

Note: See TracTickets for help on using tickets.