Opened 7 years ago

Closed 7 years ago

#49547 closed request (duplicate)

Erlang R17 (erts-6.0) needed for couchdb port to work.

Reported by: lcopps@… Owned by: ci42
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: jeff@…
Port: erlang

Description

Erlang 6.4 (otp 17.5) is needed for port couchdb to work. Currently, erlang 7.0 is available on macports which does not work with apache couchdb. The port currently available for couchdb is broken as it attempts to use an incompatible version of erlang. I was forced to install erlang 6.4 and couchdb from outside Macports.

Change History (3)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: jeff@… added
Keywords: erlang couchdb removed
Owner: changed from macports-tickets@… to ciserlohn@…
Version: 2.3.4

So this sounds like either a request for an erlang6 port to be created and for couchdb (and couchdb-devel?), or for couchdb (and couchdb-devel?) to be fixed to work with erlang 7.

comment:2 Changed 7 years ago by jeff@…

It works fine with 7 it looks like. Couchdb installer is just picky. See also #49536

comment:3 Changed 7 years ago by ci42

Resolution: duplicate
Status: newclosed
Summary: Erlang 6.4 (OTP 17.5) needed for couchdb port to work.Erlang R17 (erts-6.0) needed for couchdb port to work.

Duplicate of #49536

Note: See TracTickets for help on using tickets.