Opened 5 years ago

Closed 4 years ago

#49559 closed defect (fixed)

nepomuk-core can't be installed on a case-sensitive system

Reported by: info@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: server/hosting Version: 2.3.4
Keywords: Cc: ryandesign (Ryan Schmidt), NicosPavlov, RJVB (René Bertin)
Port: nepomuk-core

Change History (5)

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Priority: HighNormal

The Priority field is for use by Macports team members only.

comment:2 Changed 5 years ago by info@…

no problem. why is the priority field accessible to the public when we create a new ticket then ? we shouldn't have that option available if it's for your team only...

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: neponuk removed
Port: neponuk added; kdenlive removed

I'm not aware whether Trac can be configured to restrict the use of the priority field. Our ticket filing instructions make clear that it isn't to be used.

In any case, please provide in this ticket a summary of the problem. You've marked this is as a bug in base, but I don't understand what we could change in base to alter this situation.

comment:4 Changed 5 years ago by RJVB (René Bertin)

I don't think the reporter knows, nor do I.

The issue is this: nepomuk installs ${prefix}/include/nepomuk2/variant.h and ${prefix}/include/Nepomuk2/Variant. Contrary to the bug title, this installs fine on a case-*sensitive* filesystem. On case-insensitive, this leads to a single directory that contains both variant.h and Variant (and the other C-style vs. C++ style headers). The name of that directory will be nepomuk2 (not Nepomuk2 because the C-style headers are installed last. The binary package produced by the build bots show the same phenomenon, something I have reported before already. Why this happens is a mystery to me, but this would happen if the destroot that serves to create the binary package is on a case-insensitive FS, for instance.

C++ code will use #include <Nepomuk2/Variant. When the header is installed as ${prefix}/include/nepomuk2/Variant on a case-sensitive filesystem, this include statement will fail.

comment:5 in reply to:  4 Changed 4 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… nicos@… rjvbertin@… added
Component: baseserver/hosting
Port: nepomuk-core added; neponuk removed
Resolution: fixed
Status: newclosed
Summary: neponuk can't be installed on a case-sensitive systemnepomuk-core can't be installed on a case-sensitive system

Replying to rjvbertin@…:

The binary package produced by the build bots show the same phenomenon, something I have reported before already. Why this happens is a mystery to me, but this would happen if the destroot that serves to create the binary package is on a case-insensitive FS, for instance.

The new buildbot setup does not show this behavior, so I revbumped nepomuk-core in r153339 so that all the packages are correctly rebuilt for case-sensitive systems. See also #42904.

Note: See TracTickets for help on using tickets.