Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#49669 closed defect (fixed)

port upgrade outdated @ MacPorts 2.3.4 Error: Unable to open port: can't read "mpi.default": no such variable

Reported by: rioyokota@… Owned by: dstrubbe (David Strubbe)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: haspatch Cc: rlhamil, cray@…, marko.budinich@…, philip@…, mwolfram@…, ryandesign (Ryan Schmidt)
Port:

Description

On MacBook Air (13-inch, Early 2015), OS X 10.10.5, Xcode 7.1

After doing "sudo port selfupdate" today "sudo port upgrade outdated" returns the error "Error: Unable to open port: can't read "mpi.default": no such variable".

A quick Google search did not bring up anything useful.

Attachments (1)

mpi-1.0.tcl.patch (373 bytes) - added by mwolfram@… 3 years ago.
Patch to fix the missing mpi.default

Download all attachments as: .zip

Change History (17)

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Please attach the main.log file and/or indicate which port is exhibiting this problem.

comment:2 Changed 3 years ago by rioyokota@…

This is not for a specific port so there is no main.log file that I can attach. The error occurs when I do "sudo port upgrade outdated".

comment:3 Changed 3 years ago by rlhamil

Cc: rlhamil@… added

Cc Me!

comment:4 Changed 3 years ago by rlhamil

Same thing just happened to me - it must be some change picked up with the "port selfupdate" that caused this.

comment:5 Changed 3 years ago by seanfarley (Sean Farley)

Owner: changed from macports-tickets@… to dstrubbe@…

It almost certainly caused by dstrubbe's change r142438.

comment:6 Changed 3 years ago by cray@…

Cc: cray@… added

Cc Me! I am having the same issue when upgrading gnuradio.

Last edited 3 years ago by cray@… (previous) (diff)

comment:7 Changed 3 years ago by marko.budinich@…

Same error when migrating from Yosemite to El Capitan, using restore_ports script and also when trying to install boost port manually.

can't read "mpi.default": no such variable
    while executing
"if {${mpi.default} && ![mpi_variant_isset]} {
        default_variants-append +mpich
    }"
    (procedure "mpi.setup" line 87)
    invoked from within
"mpi.setup          -gcc -dragonegg"
    (file "Portfile" line 90)
    invoked from within
"source Portfile"
    invoked from within
"$workername eval source Portfile"
    (procedure "mportopen" line 41)
    invoked from within
"mportopen $portInfo(porturl) [list subport $portInfo(name)] $variantInfo"
Unable to open port 'boost': can't read "mpi.default": no such variable
    while executing
"dependenciesForPort $name $variants"
    (procedure "sort_ports" line 46)
    invoked from within
"sort_ports $portList"
    invoked from within
"set operationList [sort_ports $portList]"
    (file "./restore_ports.tcl" line 285)
Last edited 3 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:8 Changed 3 years ago by marko.budinich@…

Cc: marko.budinich@… added

Cc Me!

comment:9 Changed 3 years ago by philip@…

Cc: philip@… added

Cc Me!

Changed 3 years ago by mwolfram@…

Attachment: mpi-1.0.tcl.patch added

Patch to fix the missing mpi.default

comment:10 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: mwolfram@… ryandesign@… added
Keywords: haspatch added
Resolution: fixed
Status: newclosed

Thanks for the patch. Looks good to me. Committed in r142448.

comment:11 Changed 3 years ago by dstrubbe (David Strubbe)

Hi all, sorry about that. I built various ports using MPI in testing before committing this though, so I am confused why it worked for me without that part added in 'global' -- anyone have a thought on that?

comment:12 in reply to:  11 Changed 3 years ago by cray@…

Replying to dstrubbe@…:

Hi all, sorry about that. I built various ports using MPI in testing before committing this though, so I am confused why it worked for me without that part added in 'global' -- anyone have a thought on that?

Thanks for the quick fix!

comment:13 Changed 3 years ago by hosamani@…

Hey all, First time reporter here, please bear with me. My issue is identical to the OP. I see you guys have promptly released a patch to fix it fast. However being a novice, I am having trouble using the patch fix the issue. I have read the "how to" section and the 4.5 in the Macport guide. But unfortunately none of them speak about this scenario! Both those resources about fixing a specific port. Since this is not a port that is damaged here, could someone tell me how would I go about using the patch to fix the issue.

Thank you

comment:14 Changed 3 years ago by dstrubbe (David Strubbe)

Just do

sudo port selfupdate
sudo port upgrade outdated

There's nothing you have to do with the patch, that is something that was committed to the repository, and there are no "releases" per se; the ports repository is continually updated.

comment:15 Changed 3 years ago by hosamani@…

OK. Thank you. I realize my folly now. I was trying to upgrade the ports without updating the port tree once again after encountering the error. Looks like its all fixed now. Thank you

comment:16 Changed 3 years ago by marko.budinich@…

Thanks for the quick fix!!

Note: See TracTickets for help on using tickets.