Opened 5 years ago

Closed 7 weeks ago

#49860 closed defect (fixed)

mpv @0.11.0: You manually enabled the feature 'cocoa', but the autodetection check failed.

Reported by: mrkapqa Owned by: Ionic (Mihai Moldovan)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: havner@…
Port: mpv

Description

it failed to build on Mac mini 2.1 with Mountain Lion 10.8.5

please see attached file

Attachments (1)

main.log (124.3 KB) - added by mrkapqa 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by mrkapqa

Attachment: main.log added

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Keywords: mpv mountain lion removed
Owner: changed from macports-tickets@… to ionic@…
Type: requestdefect

In the future, please Cc the port maintainers (port info --maintainers mpv), if any. Note that a "request" ticket type is only for requesting a new port.

comment:2 Changed 4 years ago by Ionic (Mihai Moldovan)

Is this still a problem with mpv 0.17.0?

comment:3 Changed 4 years ago by ryandesign (Ryan Schmidt)

Cc: havner@… added
Summary: (mpv)(mountain lion-osx10.8.5) -configure failure: command execution failedmpv @0.11.0: You manually enabled the feature 'cocoa', but the autodetection check failed.

Has duplicate #51665.

comment:4 in reply to:  3 Changed 4 years ago by havner@…

Replying to ryandesign@…:

Has duplicate #51665.

Not sure this is a duplicate of #51665. The latter appeared for me on El Capitan. It used to work fine on Yosemite. It's not like I had this bug since 9 months. Looks the same but the underlying reason might be different.

Anyway, any means to debug and fix that? I tried to check the configure process but I'm not very efficient with python and waf. I found the check_cocoa() function but I wouldn't know how to resolve that to a cmd line compile result to check what the actual clang error is.

comment:5 Changed 4 years ago by havner@…

Funny thing. I solved it. But they way to do it was not immediately obvious.

I noticed that in the App Store on the purchased tab I could "Install" XCode, even though I had it installed. This wasn't any new purchase, just the one I previously had. It installed over that previous one and it was actually a new version. And with this XCode mpv built properly.

So the fault for me was an XCode version carried over from Yosemite. But the strange thing is there was no update notification. Like the system didn't register that I had an old version eligible for an update. And that old XCode could not work out the cocoa for El Capitan.

Anyway, from my point of view the issue is solved.

comment:6 Changed 4 years ago by Ionic (Mihai Moldovan)

Okay, so let's call your report "invalid" (also for the future, note that each new OS X version normally also brings a new Xcode version IIRC.)

I still don't know what is up with the initial report, but it might well have also been caused by a "misinstalled"/outdated Xcode version.

comment:7 Changed 4 years ago by ryandesign (Ryan Schmidt)

The 32-bit Snow Leopard buildbot worker experiences this error too.

https://build.macports.org/builders/ports-10.6_i386_legacy-builder/builds/6791

comment:8 Changed 4 years ago by Ionic (Mihai Moldovan)

Hmm, but not on x86_64...

I'd like to see the log file in the build directory, but that's probably not possible? Difficult to debug for me.

comment:9 Changed 7 weeks ago by kencu (Ken)

Resolution: fixed
Status: newclosed

We're 20 versions past this now -- no longer relevant.

Note: See TracTickets for help on using tickets.