Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#50300 closed defect (fixed)

version mismatch apscud/gringo breaking ocaml's opam. Please update aspcud

Reported by: tim@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: neverpanic (Clemens Lang)
Port: aspcud


The underlyung issue is described in this ticket: which has been triggered by the update of gringo to 4.5.4

It seems that the combination of aspcud 1.9.0 and gringo 4.5.4 is causing problems.

aspcud 1.9.0 and gringo 4.5.3 works. Apparently aspcud 1.9.1 and 4.5.3 works too (this is the combination homebrew is reported to use; it does not have opam issues)

Possibly aspcud 1.9.1 would work with 4.5.4

So this is a request to update the aspcud port.

Change History (3)

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

  • Owner changed from macports-tickets@… to ryandesign@…
  • Status changed from new to assigned

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

  • Resolution set to fixed
  • Status changed from assigned to closed

I updated aspcud to 1.9.1 in r144547.

comment:3 Changed 2 years ago by tim@…

thanks. So fast. This fixed the problem with opam.

Note: See TracTickets for help on using tickets.