Opened 5 years ago

Closed 4 years ago

#50791 closed defect (duplicate)

Installing a port with lots of uninstalled dependencies fails with "Too many open files"

Reported by: grigutis@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.3.4
Keywords: Cc: bgilbert (Benjamin Gilbert)
Port:

Description

OS X 10.11.3 (15D21) Xcode 7.2.1 (7C1002)

Attempting to install gnucash results in:

$ sudo port install gnucash
--->  Computing dependencies for gnucash
--->  Dependencies to be installed: aqbanking5-gtk gmp gnutls libtasn1 nettle p11-kit desktop-file-utils glib2 libffi libxslt gwenhywfar4-gtk gtk2 atk gobject-introspection cairo fontconfig freetype libpng libpixman xorg-xcb-util xrender xorg-renderproto py27-mako py27-beaker py27-setuptools py27-markupsafe gdk-pixbuf2 jasper jpeg shared-mime-info tiff hicolor-icon-theme pango Xft2 harfbuzz graphite2 xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-inputproto xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto libgcrypt libgpg-error ktoblzcheck libofx opensp goffice08 gconf dbus-glib dbus gnome-common autoconf-archive gtk-doc docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl fop itstool gawk py27-libxml2 openjade source-highlight boost ctags gtk3 at-spi2-atk at-spi2-core xorg-libXtst xorg-recordproto libepoxy python34 python3_select mesa xorg-dri2proto xorg-glproto intltool p5.22-getopt-long p5.22-pathtools p5.22-scalar-list-utils p5.22-xml-parser p5.22-libwww-perl p5.22-encode-locale p5.22-file-listing p5.22-http-date p5.22-html-form p5.22-http-message p5.22-io-html p5.22-lwp-mediatypes p5.22-uri p5.22-http-cookies p5.22-http-daemon p5.22-http-negotiate p5.22-lwp-protocol-https p5.22-mozilla-ca p5.22-net-http p5.22-www-robotrules orbit2 libidl policykit mozjs17 autoconf213 m4 nspr libgsf guile18 libgnomeui libbonoboui libbonobo libgnome gnome-vfs gnome-mime-data libcanberra libvorbis libogg pulseaudio fftw-3-single fftw-3 json-c libsndfile flac orc soxr speex sound-theme-freedesktop libgnomecanvas libart_lgpl libglade2 pangox-compat libgnome-keyring vala p5.22-finance-quote p5.22-datetime p5.22-datetime-locale p5.22-dist-checkconflicts p5.22-list-moreutils p5.22-exporter-tiny p5.22-sub-exporter p5.22-data-optlist p5.22-params-util p5.22-sub-install p5.22-test-fatal p5.22-test-simple p5.22-try-tiny p5.22-params-validate p5.22-module-build p5.22-cpan-meta p5.22-cpan-meta-requirements p5.22-cpan-meta-yaml p5.22-parse-cpan-meta p5.22-version p5.22-inc-latest p5.22-module-metadata p5.22-perl-ostype p5.22-podlators p5.22-pod-simple p5.22-pod-escapes p5.22-module-implementation p5.22-module-runtime p5.22-yaml p5.22-datetime-timezone p5.22-class-singleton p5.22-encode p5.22-html-tableextract p5.22-html-tree p5.22-test-exception p5.22-sub-uplevel p5.22-json p5.22-time-piece webkit-gtk bison bison-runtime enchant flex geoclue2 json-glib libsoup glib-networking gsettings-desktop-schemas libproxy gstreamer1-gst-plugins-base gstreamer1 libtheora xorg-libXv xorg-videoproto harfbuzz-icu libsecret webp yelp gnome-getting-started-docs gnome-themes-standard adwaita-icon-theme icon-naming-utils p5.22-xml-simple p5.22-xml-namespacesupport p5.22-xml-sax p5.22-xml-sax-base p5.22-xml-sax-expat librsvg libcroco gnome-backgrounds gnome-user-docs webkit2-gtk gstreamer1-gst-plugins-bad chromaprint ffmpeg XviD fribidi gmake lame libass libbluray libmodplug libopus libsdl libvpx openjpeg15 jbigkit lcms2 schroedinger texinfo x264 yasm faad2 fluidsynth jack db60 libsamplerate portaudio libGLU libdca libdvdnav libdvdread libexif libmms libmpcdec libssh2 mpg123 neon openal-soft openexr ilmbase rtmpdump soundtouch spandsp-devel x265 gstreamer1-gst-plugins-good aalib libcaca libdv libshout2 taglib wavpack hyphen libnotify yelp-xsl
--->  Fetching distfiles for gmp
--->  Verifying checksums for gmp
--->  Extracting gmp
Error: org.macports.extract for port gmp returned: Too many open files
Error: Failed to install gmp
Please see the log file for port gmp for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gmp/gmp/main.log
Error: The following dependencies were not installed: aqbanking5-gtk gmp gnutls libtasn1 nettle p11-kit desktop-file-utils glib2 libffi libxslt gwenhywfar4-gtk gtk2 atk gobject-introspection cairo fontconfig freetype libpng libpixman xorg-xcb-util xrender xorg-renderproto py27-mako py27-beaker py27-setuptools py27-markupsafe gdk-pixbuf2 jasper jpeg shared-mime-info tiff hicolor-icon-theme pango Xft2 harfbuzz graphite2 xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-inputproto xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto libgcrypt libgpg-error ktoblzcheck libofx opensp goffice08 gconf dbus-glib dbus gnome-common autoconf-archive gtk-doc docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl fop itstool gawk py27-libxml2 openjade source-highlight boost ctags gtk3 at-spi2-atk at-spi2-core xorg-libXtst xorg-recordproto libepoxy python34 python3_select mesa xorg-dri2proto xorg-glproto intltool p5.22-getopt-long p5.22-pathtools p5.22-scalar-list-utils p5.22-xml-parser p5.22-libwww-perl p5.22-encode-locale p5.22-file-listing p5.22-http-date p5.22-html-form p5.22-http-message p5.22-io-html p5.22-lwp-mediatypes p5.22-uri p5.22-http-cookies p5.22-http-daemon p5.22-http-negotiate p5.22-lwp-protocol-https p5.22-mozilla-ca p5.22-net-http p5.22-www-robotrules orbit2 libidl policykit mozjs17 autoconf213 m4 nspr libgsf guile18 libgnomeui libbonoboui libbonobo libgnome gnome-vfs gnome-mime-data libcanberra libvorbis libogg pulseaudio fftw-3-single fftw-3 json-c libsndfile flac orc soxr speex sound-theme-freedesktop libgnomecanvas libart_lgpl libglade2 pangox-compat libgnome-keyring vala p5.22-finance-quote p5.22-datetime p5.22-datetime-locale p5.22-dist-checkconflicts p5.22-list-moreutils p5.22-exporter-tiny p5.22-sub-exporter p5.22-data-optlist p5.22-params-util p5.22-sub-install p5.22-test-fatal p5.22-test-simple p5.22-try-tiny p5.22-params-validate p5.22-module-build p5.22-cpan-meta p5.22-cpan-meta-requirements p5.22-cpan-meta-yaml p5.22-parse-cpan-meta p5.22-version p5.22-inc-latest p5.22-module-metadata p5.22-perl-ostype p5.22-podlators p5.22-pod-simple p5.22-pod-escapes p5.22-module-implementation p5.22-module-runtime p5.22-yaml p5.22-datetime-timezone p5.22-class-singleton p5.22-encode p5.22-html-tableextract p5.22-html-tree p5.22-test-exception p5.22-sub-uplevel p5.22-json p5.22-time-piece webkit-gtk bison bison-runtime enchant flex geoclue2 json-glib libsoup glib-networking gsettings-desktop-schemas libproxy gstreamer1-gst-plugins-base gstreamer1 libtheora xorg-libXv xorg-videoproto harfbuzz-icu libsecret webp yelp gnome-getting-started-docs gnome-themes-standard adwaita-icon-theme icon-naming-utils p5.22-xml-simple p5.22-xml-namespacesupport p5.22-xml-sax p5.22-xml-sax-base p5.22-xml-sax-expat librsvg libcroco gnome-backgrounds gnome-user-docs webkit2-gtk gstreamer1-gst-plugins-bad chromaprint ffmpeg XviD fribidi gmake lame libass libbluray libmodplug libopus libsdl libvpx openjpeg15 jbigkit lcms2 schroedinger texinfo x264 yasm faad2 fluidsynth jack db60 libsamplerate portaudio libGLU libdca libdvdnav libdvdread libexif libmms libmpcdec libssh2 mpg123 neon openal-soft openexr ilmbase rtmpdump soundtouch spandsp-devel x265 gstreamer1-gst-plugins-good aalib libcaca libdv libshout2 taglib wavpack hyphen libnotify yelp-xsl
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port gnucash failed

The last iteration of sudo lsof -c tclsh +r 1 shows 262 open files.

gmp will install by itself, so it's probably just the large number of dependencies for gnucash.

Attachments (2)

main.log (3.6 KB) - added by grigutis@… 5 years ago.
lsof.txt (35.4 KB) - added by grigutis@… 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by grigutis@…

Attachment: main.log added

Changed 5 years ago by grigutis@…

Attachment: lsof.txt added

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: dports@… removed
Component: portsbase
Port: gnucash removed
Summary: gnucash @2.6.11 can't install: "Too many open files"Installing a port with lots of uninstalled dependencies fails with "Too many open files"

This sounds like a longstanding MacPorts base issue. I'm not sure if we already have a ticket for it. The workaround is to break the install into smaller groups of ports.

comment:2 Changed 5 years ago by nortcele

The problem is frequently seen with OS X 10.11 as the max opened files per process is severely reduced.

With OS X 10.9.5 "sysctl -A | grep kern.maxfiles" returned

kern.maxfiles: 300000
kern.maxfilesperproc: 150000

With 10.11.4 the result is

kern.maxfiles: 300000
kern.maxfilesperproc: 10240

So it went from 150k to 1k!

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

#51371 might be a duplicate.

comment:4 Changed 4 years ago by bgilbert (Benjamin Gilbert)

Cc: bgilbert@… added

Cc Me!

comment:5 Changed 4 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

I think we can call this a duplicate of #50986.

Note: See TracTickets for help on using tickets.