Opened 14 years ago

Closed 14 years ago

#5095 closed defect (fixed)

UPDATE: py-gnome-2.11.3

Reported by: rjt-bugzilla@… Owned by: pguyot (Paul Guyot)
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: olaf@…
Port:

Description

py-gnome-2.11.3

the portfile can be found here: ATTACHED

Description: port update to much newer version of py-gnome. Port just updates the version number a path and includes a new set of patches to make the _init_ methods behave themselves.

Homepage: http://www.daa.com.au/~james/software/pygtk/

Comments: These update is required for the py-gramps port that I have submitted. The 2.0 port has a bug that means that the _init_pyorbit function is not in the library and import gnome.ui fails. The 2.0 version of python-gnome does not contain some of the vfs functions that gramps requires.

Attachments (2)

Portfile.diff (1.4 KB) - added by rjt-bugzilla@… 14 years ago.
portfile diff for py-gnome 2.0 to 2.11.3
files.tgz (782 bytes) - added by rjt-bugzilla@… 14 years ago.
tarball of patch files required for py-gnome-2.11.3 port

Download all attachments as: .zip

Change History (7)

Changed 14 years ago by rjt-bugzilla@…

Attachment: Portfile.diff added

portfile diff for py-gnome 2.0 to 2.11.3

Changed 14 years ago by rjt-bugzilla@…

Attachment: files.tgz added

tarball of patch files required for py-gnome-2.11.3 port

comment:1 Changed 14 years ago by pguyot (Paul Guyot)

Status: newassigned

I had a 2.11.3 half working, I trashed it in favor of yours but yours doesn't install here (10.4.2).

/usr/bin/ld: warning -prebind has no effect with -bundle /usr/bin/ld: can't locate file for: -lpython2.4 collect2: ld returned 1 exit status make[2]: * [libpythonmethod.la] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

python24 is installed.

I'll have a look later.

comment:2 Changed 14 years ago by rjt-bugzilla@…

That is rather strange. My setup was a completely virgin install of darwinports. I just installed darwinports and typed 'port install py-gnome'. After some fighting with missing dependencies (not in py-gnome) I finally got the 2.0 port built. I think uninstalled the 2.0 port, made my changes and installed the new port. I never saw this problem along the way. Richard

comment:3 Changed 14 years ago by mww@…

Cc: olaf@… added

* Bug 5470 has been marked as a duplicate of this bug. *

comment:4 Changed 14 years ago by pguyot (Paul Guyot)

dependson: 5493

comment:5 Changed 14 years ago by pguyot (Paul Guyot)

Resolution: fixed
Status: assignedclosed

Bumped to 2.12.1. Thanks Olaf.

Note: See TracTickets for help on using tickets.