Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#51033 closed defect (duplicate)

Libspectre won't upgrade on Mac OS X 10.6.8, Snow Leopard

Reported by: ballapete (Peter Dyballa) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: dbevans (David B. Evans), StanSanderson
Port: libspectre

Description

That's the error:

  CC     libspectre_la-spectre-exporter-pdf.lo
spectre-gs.c: In function 'critic_error_code':
spectre-gs.c:46: error: 'e_Fatal' undeclared (first use in this function)
spectre-gs.c:46: error: (Each undeclared identifier is reported only once
spectre-gs.c:46: error: for each function it appears in.)
spectre-gs.c:51: error: 'e_ExecStackUnderflow' undeclared (first use in this function)
spectre-gs.c: In function 'spectre_gs_process':
spectre-gs.c:112: error: 'e_NeedInput' undeclared (first use in this function)

Could be the upgrade to Ghostscript 9.19 removed the GS header file(s) with their declarations…

Indeed! In Ghostscript 9.06 I found:

include/ghostscript/ierrors.h:#define e_Fatal (-100)
include/ghostscript/ierrors.h:#define e_ExecStackUnderflow (-104)
include/ghostscript/ierrors.h:#define e_NeedInput (-106)

Attachments (1)

main.log (20.8 KB) - added by ballapete (Peter Dyballa) 3 years ago.

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by ballapete (Peter Dyballa)

Attachment: main.log added

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: openmaintainer@… removed
Resolution: duplicate
Status: newclosed

Duplicate of #51031.

comment:2 Changed 3 years ago by StanSanderson

Cc: stansand@… added

Cc Me!

Note: See TracTickets for help on using tickets.