Opened 3 years ago

Closed 2 years ago

#51256 closed defect (fixed)

pcb won't build

Reported by: TimNightingale Owned by: technobauble (Chad Parker)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: pcb

Description

pcb (version 20140316) won't build. It falls over when testing the gd library for the gdImageGif function. I note that GIF support was removed from the GD library in Version 1.6 and added back in version 2.0.28 (see http://php.net/manual/en/function.imagegif.php). MacPorts currently has a gd2 port (version 2.1.1.1). Will pcb build with that?

Thanks,

Tim.

Attachments (2)

main.log (165.3 KB) - added by TimNightingale 3 years ago.
build log for pcb
config.log (292.9 KB) - added by TimNightingale 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by TimNightingale

Attachment: main.log added

build log for pcb

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

It installs fine for me. Please attach the file /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_pcb/pcb/work/pcb-20140316/config.log; it might contain more information.

Changed 3 years ago by TimNightingale

Attachment: config.log added

comment:2 Changed 3 years ago by TimNightingale

Thanks for responding. config.log attached.

Tim.

comment:3 Changed 3 years ago by rbsanti@…

I have the same problem. Solution?

Thanks

comment:4 Changed 2 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to technobauble
Status: newassigned

comment:5 Changed 2 years ago by mf2k (Frank Schima)

pcb and gd2 have both been updated. Is this still an issue?

comment:6 Changed 2 years ago by technobauble (Chad Parker)

I have no issues building... but I'm a developer, not just a user.

@TimNightingale, it looks like gd was built and linked against the vpx library (?), and that library is no longer available. If you're still having a problem, I'd suggest rebuilding the gd port and then try to build pcb again.

@rbsanti, if you're still having a problem with the new version of pcb, please post your logs and I'll have a look.

comment:7 Changed 2 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: assignedclosed

Closing this as fixed. Please re-open the ticket with a complete build log if this is still a problem.

Note: See TracTickets for help on using tickets.