Opened 4 years ago

Closed 4 years ago

#51470 closed defect (fixed)

openexr @2.2.0 compile fails

Reported by: joergahrens (Jörg Ahrens) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: blair (Blair Zajac), hapaguy (Brian Kurt Fujikawa), sebastian@…, macports.org@…, Schamschula (Marius Schamschula), szhorvat (Szabolcs Horvát), ballapete (Peter Dyballa)
Port: openexr

Description

Error: org.macports.build for port openexr returned: command execution failed Please see the log file for port openexr for details:

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_openexr/openexr/main.log

Error: Unable to upgrade port: 1 Error: Unable to execute port: upgrade openexr failed

Attachments (3)

main.log (163.5 KB) - added by joergahrens (Jörg Ahrens) 4 years ago.
patch-too-long-long.diff (1.2 KB) - added by ballapete (Peter Dyballa) 4 years ago.
Patch for too long longs on Tiger
openexr_main.log (129.6 KB) - added by arboz@… 4 years ago.
for Leopard/intel i386 build

Download all attachments as: .zip

Change History (27)

Changed 4 years ago by joergahrens (Jörg Ahrens)

Attachment: main.log added

comment:1 Changed 4 years ago by hapaguy (Brian Kurt Fujikawa)

Cc: brian.fujikawa@… added

Cc Me!

comment:2 Changed 4 years ago by sebastian@…

Cc: sebastian@… added

Cc Me!

comment:3 Changed 4 years ago by macports.org@…

Cc: macports.org@… added

Cc Me!

comment:4 Changed 4 years ago by Schamschula (Marius Schamschula)

Cc: mps@… added

Cc Me!

comment:5 Changed 4 years ago by Schamschula (Marius Schamschula)

Owner: changed from macports-tickets@… to mcalhoun@…

comment:6 Changed 4 years ago by jmroot (Joshua Root)

Cc: blair@… added

comment:7 Changed 4 years ago by szhorvat (Szabolcs Horvát)

Cc: szhorvat@… added

Cc Me!

comment:8 Changed 4 years ago by Schamschula (Marius Schamschula)

Last edited 4 years ago by Schamschula (Marius Schamschula) (previous) (diff)

comment:9 Changed 4 years ago by ballapete (Peter Dyballa)

Cc: Peter_Dyballa@… added

Cc Me!

comment:10 Changed 4 years ago by ballapete (Peter Dyballa)

On PPC Tiger, Mac OS X 10.4.11, another error occurs: the values 0xffffffffffffffffLset on lines #110, 355, 365, 420, and 530 are found erroneous by GCC 4..2.4, apple-gcc42 @5666.3_15+gpl3 (active).

On line #100 the base array is declared as of type Int64, which is #typedef'ed in include/OpenEXR/ImathInt64.h as long long unsigned int. GCC 4.2.4 has #defined:

#define LONG_LONG_MAX __LONG_LONG_MAX__
#define ULONG_LONG_MAX (LONG_LONG_MAX * 2ULL + 1ULL)

with

#define __LONG_LONG_MAX__ 9223372036854775807LL

as a built-in #define. Other PPC limits:

#define ULONG_MAX 0xffffffffL
#define LONG_MAX 2147483647L

#define ULLONG_MAX 0xffffffffffffffffULL

So obviously the too simplistic code à la = 0xffffffffffffffffL; has to be corrected as = 0xffffffffffffffffULL;. This is accomplished by my patch file.

Changed 4 years ago by ballapete (Peter Dyballa)

Attachment: patch-too-long-long.diff added

Patch for too long longs on Tiger

comment:11 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Status: newassigned

During the upgrade process, openexr is including the header files located in ${prefix}/include/OpenEXR.
I was able to fix that problem, but then openexr tries to link against the old openexr libraries in ${prefix}/lib.
I am still working on that one.

I know this kind of problem has come up before with other ports, but I can not seem to find the reference, much less an easy solution.

comment:12 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

With any luck, r148921 fixed both problems.
In the future, it is probably best to open a new ticket for a separate error.

Can openexr now upgrade?

comment:13 in reply to:  12 Changed 4 years ago by sebastian@…

Replying to mcalhoun@…:

Can openexr now upgrade?

When I tried just now, the upgrade used a binary package – so it worked for me, but I can't tell whether the patch fixed the issue.

comment:14 Changed 4 years ago by khepler

Builds on Leopard/PPC.

comment:15 in reply to:  14 Changed 4 years ago by arboz@…

Replying to khepler@…:

Builds on Leopard/PPC.

Leopard i386 still seems to have some problem.

Recently, there seems to be some issue with asm.

info:build /bin/sh ../libtool --tag=CXX --mode=compile /usr/bin/g++-4.2 -DHAVE_CONFIG_H -I. -I../config -I.. -I../config -D_THREAD_SAFE -I/opt/local/include/OpenEXR -I/opt/local/include -pipe -pipe -Os -arch i386 -MT ImfZip.lo -MD -MP -MF .deps/ImfZip.Tpo -c -o ImfZip.lo 
ImfZip.cpp 

info:build ImfSystemSpecific.cpp: In constructor ‘Imf_2_2::CpuId::CpuId()’: 

info:build ImfSystemSpecific.cpp:51: error: can't find a register in class ‘BREG’ while reloading ‘asm’ 

info:build ImfSystemSpecific.cpp:51: error: can't find a register in class ‘BREG’ while reloading ‘asm’ 

info:build ImfSystemSpecific.cpp:51: error: ‘asm’ operand has impossible constraints 

info:build ImfSystemSpecific.cpp:51: error: ‘asm’ operand has impossible constraints 

info:build make[2]: *** [ImfSystemSpecific.lo] Error 1

...

attaching main.log

Last edited 4 years ago by arboz@… (previous) (diff)

Changed 4 years ago by arboz@…

Attachment: openexr_main.log added

for Leopard/intel i386 build

comment:16 in reply to:  12 Changed 4 years ago by arboz@…

Replying to mcalhoun@…:

With any luck, r148921 fixed both problems.
In the future, it is probably best to open a new ticket for a separate error.

Can openexr now upgrade?

Sorry I may have replied to wrong message before. my Leopard/intel is still failing, details are attached

comment:17 in reply to:  12 Changed 4 years ago by ballapete (Peter Dyballa)

Replying to mcalhoun@…:

Can openexr now upgrade?

I can test on the weekend when I'll be home again.

comment:18 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Hopefully, r149026 fixed the Leopard i386 error.

comment:19 Changed 4 years ago by blair (Blair Zajac)

mcalhoun@…: I suggest adding yourself as a maintainer to the port so you get the build emails from the buildbots.

comment:20 in reply to:  18 Changed 4 years ago by arboz@…

Replying to mcalhoun@…:

Hopefully, r149026 fixed the Leopard i386 error.

The newest patch allowed it to build for me on darwin 9.8.0 Leopard i386

--->  Deactivating openexr @1.7.0_0
--->  Cleaning openexr
--->  Removing work directory for openexr
--->  Activating openexr @2.2.0_1

thanks.

comment:21 in reply to:  14 Changed 4 years ago by ballapete (Peter Dyballa)

Here too!

comment:22 Changed 4 years ago by ballapete (Peter Dyballa)

It also built on PPC Tiger, Mac OS X 10.4.11.

comment:23 in reply to:  14 Changed 4 years ago by joergahrens (Jörg Ahrens)

Replying to khepler@…:

Builds on Leopard/PPC.

Got bin packages for 10.6.8 and 10.10.5 today so it obviously builds.

comment:24 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: assignedclosed

Several issues have been raised in this ticket, but I believe they have all been addressed.
Thanks to all for the assistance.

Note: See TracTickets for help on using tickets.