Opened 5 years ago

Closed 5 years ago

#51827 closed defect (duplicate)

zeroc-ice35: error: expression with side effects will be evaluated despite being used as an operand to 'typeid'

Reported by: g.korovkin@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: zeroc-ice35

Description (last modified by ryandesign (Ryan Schmidt))

after trying to upgade port - zeroc-ice35 port has failed to compile:

:info:build BackgroundSaveEvictorI.cpp:1077:56: error: expression with side effects will be evaluated despite being used as an operand to 'typeid' [-Werror,-Wpotentially-evaluated-expression]
:info:build                             ex.message = string(typeid(*element->rec.servant).name()) 
:info:build                                                        ^
:info:build 1 error generated.
:info:build make[2]: *** [BackgroundSaveEvictorI.o] Error 1
:info:build make[1]: *** [Freeze] Error 2

Attachments (1)

main.log (15.9 KB) - added by g.korovkin@… 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by g.korovkin@…

Attachment: main.log added

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to blair@…
Summary: zeroc-ice35 failed to buildzeroc-ice35: error: expression with side effects will be evaluated despite being used as an operand to 'typeid'

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #50075.

Note: See TracTickets for help on using tickets.