#51845 closed submission (fixed)

New port: stlink

Reported by: denis-fr (Denis) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: stlink

Description

Texane stlink is an Open source version of the STMicroelectronics Stlink Tools.
https://github.com/texane/stlink
Variant +gui is not working on snow leopard (10.6). I was tested on Yosemite (10.10)

Attachments (3)

Portfile (872 bytes) - added by denis-fr (Denis) 17 months ago.
Portfile
Portfile.2 (1.0 KB) - added by denis-fr (Denis) 17 months ago.
Portfile for version 1.2.0
Portfile.3 (1.0 KB) - added by denis-fr (Denis) 14 months ago.
dependency on path:lib/libusb-1.0.dylib:libusb

Download all attachments as: .zip

Change History (10)

Changed 17 months ago by denis-fr (Denis)

Portfile

comment:1 Changed 17 months ago by ryandesign (Ryan Schmidt)

Could you use the 1.2.0 tag instead of fetching from an arbitrary commit?

Could you fetch a tarball instead of using git? (Remove fetch.type git; add checksums.)

use_configure yes is not needed; that's the default.

Are you sure depends_build-append port:autogen is needed? I looked at the project's autogen.sh script, and all it does is call autoreconf, which is part of the autoconf port, which is already added as a dependency thanks to use_autoconf yes. The autogen port is not typically needed.

comment:2 Changed 17 months ago by denis-fr (Denis)

Thanks, I modify Portfile file according your feed-backs to build 1.2.0 tag version.

Changed 17 months ago by denis-fr (Denis)

Portfile for version 1.2.0

comment:3 Changed 17 months ago by mf2k (Frank Schima)

  • Port stlink added
  • Type changed from request to submission
  • Version 2.3.4 deleted

comment:4 Changed 15 months ago by denis-fr (Denis)

Any news? When will it be available?

comment:5 follow-up: Changed 15 months ago by mf2k (Frank Schima)

Comments:

  • Can the dependency on libusb be changed to path:lib/libusb-1.0.dylib:libusb to allow use of the libusb-devel?
  • As someone who wants to minimize variants, is it realistic for users to install this port without the GUI? Can it be switched to a subport?

Changed 14 months ago by denis-fr (Denis)

dependency on path:lib/libusb-1.0.dylib:libusb

comment:6 in reply to: ↑ 5 Changed 14 months ago by denis-fr (Denis)

Replying to mf2k@…:

  • Can the dependency on libusb be changed to path:lib/libusb-1.0.dylib:libusb to allow use of the libusb-devel?

Done.

  • As someone who wants to minimize variants, is it realistic for users to install this port without the GUI? Can it be switched to a support?

Gui is not necessary. Personally, I never use it. What do you call a subport, can you give me the name of a subport?

comment:7 Changed 14 months ago by mf2k (Frank Schima)

  • Resolution set to fixed
  • Status changed from new to closed

The variant is fine. r153829.

Note: See TracTickets for help on using tickets.