#51901 closed defect (fixed)

dub requires additional ports to build

Reported by: rnowling@… Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: dub

Description

I tried running installing dub with sudo port install dub but received an error about the build failing. On the suggestion ofthe dmd port installation, I installed druntime, phobos, and dmd-tools. I then re-ran the dub install, which succeeded. Since dub only depends on dmd, I suggest that the port be updated to include druntime, phobos, and/or dmd-tools to fix the build. I'm not sure if it requires all three or just a subset.

I'm running on OS X 10.10.5.

Change History (2)

comment:1 Changed 16 months ago by ryandesign (Ryan Schmidt)

  • Owner changed from macports-tickets@… to sean@…

comment:2 Changed 16 months ago by seanfarley (Sean Farley)

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for reporting! Fixed in r150662.

Note: See TracTickets for help on using tickets.