Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#52106 closed defect (duplicate)

Perl5.2.2 fails to build in Sierra

Reported by: summers@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: sierra Cc:
Port: perl5.22

Description (last modified by mojca (Mojca Miklavec))

Fails when trying to install perl5. NOTE: lbzip2 is not listed as a dependency when attempting to install perl5 (but is clearly required).

:info:build Updating 'mktables.lst'
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_perl5/perl5.22/work/perl-5.22.2'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_perl5/perl5.22/work/perl-5.22.2" && /usr/bin/make -j4 -w all
:info:build Exit code: 2
:error:build Failed to build perl5.22: command execution failed
:debug:build Error code: CHILDSTATUS 49205 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_perl5/perl5.22/main.log for details.

Attachments (1)

main.log (149.6 KB) - added by summers@… 4 years ago.
Log file for perl5 failure on Sierra

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by summers@…

Attachment: main.log added

Log file for perl5 failure on Sierra

comment:1 Changed 4 years ago by larryv (Lawrence Velázquez)

Keywords: sierra added
Port: perl5.22 added
Resolution: duplicate
Status: newclosed
Version: 2.3.4

Duplicate of #51980.

comment:2 Changed 4 years ago by mojca (Mojca Miklavec)

Description: modified (diff)

I believe that lbzip2 gets pulled automatically due to

use_bzip2           yes
Note: See TracTickets for help on using tickets.