Opened 4 years ago

Closed 3 years ago

#52384 closed defect (fixed)

hexchat: uses installed headers opportunistically

Reported by: Ionic (Mihai Moldovan) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: hexchat

Description (last modified by Ionic (Mihai Moldovan))

hexchat uses the already installed system headers, if possible.

Trace mode helps in such cases, but let's fix this opportunistic usage anyway.

This patch should be applied before #52385.

Just for review, if you're okay with it I can apply it myself.

Attachments (1)

hexchat-no-system-hexchat-includes.patch (792 bytes) - added by Ionic (Mihai Moldovan) 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by Ionic (Mihai Moldovan)

comment:1 Changed 4 years ago by Ionic (Mihai Moldovan)

Description: modified (diff)

comment:2 Changed 4 years ago by larryv (Lawrence Velázquez)

Unless this is actually causing build problems, I’m not sure there’s a good reason to do this. Broader discussion at #40656.

comment:3 Changed 4 years ago by raimue (Rainer Müller)

Status: newassigned

This can just be fixed in hexchat build system by reordering the include arguments.

Pull request submitted upstream: https://github.com/hexchat/hexchat/pull/1822

comment:4 Changed 4 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: assignedclosed

Fixed in r153195.

comment:5 Changed 3 years ago by Ionic (Mihai Moldovan)

Resolution: fixed
Status: closedreopened

Reopening, since it's back with the meson build system.

Haven't seen problems caused by this yet, but let's be aware of it.

comment:6 Changed 3 years ago by raimue (Rainer Müller)

Thanks for noticing!

I submitted a pull request to upstream to fix it: https://github.com/hexchat/hexchat/pull/2155

comment:7 Changed 3 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: reopenedclosed

In 8bc35d78111857851ef813bb0447e86b0dc2ce95/macports-ports:

hexchat: Do not use header of installed port

Closes: #52384

Note: See TracTickets for help on using tickets.