Opened 4 years ago

Closed 4 years ago

#52402 closed defect (fixed)

Update empathy to use webkit2-gtk

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: empathy

Description

Please update empathy to use webkit2-gtk rather than webkit-gtk.

The older version of webkit-gtk hasn't been supported upstream for quite some time and is full of vulnerabilities.

See #52398

Change History (2)

comment:1 Changed 4 years ago by dbevans (David B. Evans)

Status: newassigned

Very little upstream development going on due to lack of maintainers. However, there is an upstream ticket for the issue with a WIP patch. Not ready for commit yet but it's a start. See https://bugzilla.gnome.org/show_bug.cgi?id=749001.

comment:2 Changed 4 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: assignedclosed

In ae7185b13a2c3e4d449cbb9851d2de24757b5595/macports-ports:

empathy: update to version 3.12.14, dependencies

Now uses webkit2-gtk.

Closes #52402

Note: See TracTickets for help on using tickets.