Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#52475 closed defect (fixed)

rabbitmq-server: rabbitmq_management

Reported by: gulios@… Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: rabbitmq-server

Description

Hi,

There is an issue(maybe connected to port or version) It's not possible to enable management plugin.

sudo rabbitmq-plugins enable rabbitmq_management
Error: {cannot_read_enabled_plugins_file,
"/opt/local/lib/rabbitmq/lib/rabbitmq_server-3.6.5/etc/rabbitmq/enabled_plugins",
           eisdir}

Thx

Change History (6)

comment:1 Changed 5 years ago by seanfarley (Sean Farley)

Owner: changed from macports-tickets@… to sean@…
Status: newassigned

I'll try to work on this if I have free time but if someone else gets to it, that'd be great.

comment:2 Changed 5 years ago by sblackstone (Stephen Blackstone)

All you need to do is create the missing directory it writes to:

e.g

sudo mkdir -p /opt/local/lib/rabbitmq/lib/rabbitmq_server-3.6.5/etc/rabbitmq

comment:3 Changed 4 years ago by bpanulla (Brian Panulla)

I think the problem is it's not finding a setting. The enabled_plugins file for my previous install was in /opt/local/etc/rabbitmq/enabled_plugins. It seems like it's expecting another config variable to tell it this, but when it is not present it's assuming it should go under the server lib directory.

comment:4 Changed 4 years ago by l2dy (Zero King)

Resolution: fixed
Status: assignedclosed

In f50ef68067e45e0409fc2e7ecb2971f4c1114b7e/macports-ports:

rabbitmq-server: update to 3.6.12, fix reinplace

Fixes: #52475

comment:5 Changed 4 years ago by l2dy (Zero King)

Keywords: rabbit removed
Summary: rabbitmq_managementrabbitmq-server: rabbitmq_management
Version: 2.3.4

Please check if the fix works.

comment:6 Changed 4 years ago by l2dy (Zero King)

In f50ef68067e45e0409fc2e7ecb2971f4c1114b7e/macports-ports:

rabbitmq-server: update to 3.6.12, fix reinplace

Fixes: #52475

Note: See TracTickets for help on using tickets.