Opened 4 years ago

Closed 4 years ago

#52578 closed defect (fixed)

imlib and dependents: remove outdated GTK1/GNOME1 ports

Reported by: dbevans (David B. Evans) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: removal Cc:
Port: imlib e16menuedit fnlib gtk-engines imecho

Description

I'm proposing to remove imlib and its 4 remaining dependents from MacPorts. These are obsolete ports from the gtk1 era (middle to late 1990's, gtk+ 2.0.0 was released 2002-03-08), are unmaintained and and have no other dependents.

Here's the list with proposed actions to be performed

  • imlib (mark obsolete, replaced by imlib2, no dependents beyond the 4 following)
  • e16menuedit (remove, no dependents)
  • fnlib (remove, no dependents)
  • gtk-engines (mark obsolete, replaced by gtk-engines2, no dependents)
  • imecho (remove, no dependents)

If you know of reason why any of these should NOT be removed, please respond this week as, in the absence of any response, I plan to carry out these actions early next week. I can't imagine there should be any objections but just in case ...

Change History (1)

comment:1 Changed 4 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

r153916: gtk-engines marked obsolete, replaced by gtk-engines2
r153917: remaining dependents of imlib removed, imlib marked obsolete, replaced by imlib2

Note: See TracTickets for help on using tickets.