Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#52907 closed defect (wontfix)

Cmus @ MacOs 10.5.8 PowerPC - Lib

Reported by: mrkapqa Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: leopard powerpc upstream Cc:
Port: libsdl2

Description

hello ,

i tried to install cmus on Powerpc G4

and fails everytime

Building libsdl2 @2.0.5 on Mac OS X 10.6 requires the MacOSX10.7.sdk to be present in /Developer/SDKs/

while executing

i use Leopard 10.5.8

thank you

richard

Attachments (1)

desktop (1.7 KB) - added by mrkapqa 4 years ago.

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by mrkapqa

Attachment: desktop added

comment:1 Changed 4 years ago by mf2k (Frank Schima)

In the future, please use WikiFormatting, fill in the Port field and Cc the port maintainers (port info --maintainers cmus), if any.

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Cc: g5pw added
Keywords: cmus powerpc leopard libsd12 removed
Port: cmus added

comment:3 Changed 4 years ago by mf2k (Frank Schima)

Keywords: leopard powerpc added

comment:4 Changed 4 years ago by mf2k (Frank Schima)

Cc: g5pw removed
Owner: changed from macports-tickets@… to g5pw
Status: newassigned

comment:5 Changed 4 years ago by g5pw (Aljaž Srebrnič)

Owner: changed from g5pw to jmroot
Port: libsdl2 added; cmus removed

There are a couple of issues with the log:

  • It isn't a clean build attempt. You need to execute sudo port clean libsdl2 and try again for a complete log.
  • This isn't an issue with cmus. It's an issue with libsdl2.
  • Please note that Leopard (and PowerPC) is considered not supported.

comment:6 Changed 4 years ago by ken-cunningham-webuse

I don't imagine libsdl2 will ever be supported on PowerPC, and even Leopard Intel is presently somewhat of a long shot in macports, although theoretically can be done apparently. So you'll need to try something else.

cmus requires ffmpeg I see, so most likely you're getting stuck by the new requirement for ffmpeg to use libsdl2. So that would be your place to start working towards.

As a first practical step, you might try installing an older version of ffmpeg that still used libsdl, and go from there.

google "installing an older version of a port" for instructions how to do it -- there's a wiki page here for that.

comment:7 Changed 4 years ago by mrkapqa

Hello ,

had installed cmus via tigerbrew or macports very recently and it worked withouth problems.

sorry for my mis-format . i think it was tigerbrew but am not sure.

on tigerbrew missing is now mp4v2 solely because the download link on which it relys is no more active . does anyone know how to correct this?

it says

"download failed: https://mp3v1.google.code.com/files/mp4v2-2.0.0.tar.bz"

the new adress should be this "https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/mp4v2/mp4v2-2.0.0.tar.bz2"

thanks

comment:8 Changed 4 years ago by mrkapqa

sorry, i think id did not remember correctly, probably i had it installed this way here

https://cmus.github.io/#download

i think you can close this altough it would be nice to get it running via macports or tigerbrew its good program very nice !

comment:9 Changed 4 years ago by jmroot (Joshua Root)

Keywords: upstream added
Resolution: wontfix
Status: assignedclosed

If you can get whatever patches tigerbrew used accepted upstream, great. We would then pick them up in a future release. I don't have the hardware to even think about working on this though, sorry.

comment:10 Changed 4 years ago by ken-cunningham-webuse

Hey there mrkapqa,

Just to let you know I had success installing cmus

cmus @2.7.1_2+aac+cue+ffmpeg+flac+mikmod+mpc+wavpack (active) platform='darwin 8' archs='ppc'

on MacOSX 10.4 Tiger today, so presumably you can also do it on the newer PPC Leopard.

All that was needed was to slightly downgrade ffmpeg to the version from a few weeks ago that still supported libsdl

  ffmpeg @3.1.4_0+gpl2+nonfree+x11 (active) platform='darwin 8' archs='ppc'

Thanks - this looks like a great music player for these older machines to use. -- hope this helps -- K

Note: See TracTickets for help on using tickets.