Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#52987 closed defect (duplicate)

octave (4.0.3) fails on texi2dvi check

Reported by: claudiopolis Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.3.5
Keywords: Cc:
Port: octave

Description (last modified by larryv (Lawrence Velázquez))

See error below:

Making install in interpreter
make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/work/octave-4.0.3/doc/interpreter'
./config-images.sh ../..
../../doc/interpreter/images.mk is unchanged
  MAKEINFO octave.info
  TEXI2DVI octave.dvi
/opt/local/bin/texi2dvi: TeX neither supports -recorder nor outputs \openout lines in its log file
make[3]: *** [octave.dvi] Error 1
make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/work/octave-4.0.3/doc/interpreter'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/work/octave-4.0.3/doc'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/work/octave-4.0.3'
make: *** [install] Error 2
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/work/octave-4.0.3'
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/work/octave-4.0.3" && /usr/bin/make -w install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/work/destroot 
Exit code: 2
Error: org.macports.destroot for port octave returned: command execution failed
Warning: targets not executed for octave: org.macports.activate org.macports.destroot org.macports.install
Error: Failed to install octave
Please see the log file for port octave for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/main.log
Error: The following dependencies were not installed: octave
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port octave-benchmark failed

Change History (2)

comment:1 Changed 2 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Probably a duplicate of #46105. As a workaround, install latex and pdflatex manually.

comment:2 Changed 2 years ago by claudiopolis

Thanks. Workaround does the trick.

Note: See TracTickets for help on using tickets.