Opened 2 years ago

Closed 2 years ago

#53065 closed defect (fixed)

QGIS @2.18.0 build failure

Reported by: BuddyVolly Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.3.5
Keywords: Cc: fvaccari, EJFielding (Eric Fielding)
Port: QGIS

Description

Hello, I am using a MacBook Pro early 2011 with El Capitano 10.11.6 I just upgraded from MacPorts 2.3.4 to 2.3.5. After that I upgraded the outdated port which included the upgrade from qgis 2.16.3 to 2.18. This fails with the following messages:

--->  Computing dependencies for QGIS
--->  Fetching archive for QGIS
Warning: Your DNS servers incorrectly claim to know the address of nonexistent hosts. This may cause checksum mismatches for some ports. See this page for more information: <https://trac.macports.org/wiki/MisbehavingServers>
--->  Attempting to fetch QGIS-2_18_0_1+postgresql95+qt4.darwin_15.x86_64.tbz2 from http://fco.it.packages.macports.org/mirrors/macports-packages/QGIS/QGIS
--->  Attempting to fetch QGIS-2_18_0_1+postgresql95+qt4.darwin_15.x86_64.tbz2 from https://packages.macports.org/QGIS
--->  Attempting to fetch QGIS-2_18_0_1+postgresql95+qt4.darwin_15.x86_64.tbz2 from http://lil.fr.packages.macports.org/QGIS
--->  Fetching distfiles for QGIS
--->  Verifying checksums for QGIS
--->  Extracting QGIS
--->  Applying patches to QGIS
--->  Configuring QGIS
Error: org.macports.configure for port QGIS returned: configure failure: command execution failed
Please see the log file for port QGIS for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_qgis/QGIS/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port qgis failed

Find the complete log file attached. Line 2229-2230 indicate that there might be a problem with QScintilla.
Any help is much appreciated, many thanks,

Andreas

Attachments (1)

main.log (184.8 KB) - added by BuddyVolly 2 years ago.
main logfile

Download all attachments as: .zip

Change History (12)

Changed 2 years ago by BuddyVolly

Attachment: main.log added

main logfile

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

Owner: set to Veence
Port: QGIS added; qgis removed
Status: newassigned
Summary: qgis @2.18.0 build failureQGIS @2.18.0 build failure

comment:2 Changed 2 years ago by cmutel (Chris Mutel)

The problem isn't QScintilla, but QCA (crypto stuff). Some recent changes to QCA in 2.1.0_4 to improve compatibility with QT4 and QT5 somehow broke QGis finding the QCA library or headers. Downgrading to 2.1.0_3+qt4 solved the problem for me.

comment:3 Changed 2 years ago by fvaccari

Cc: fvaccari added

comment:4 Changed 2 years ago by BuddyVolly

Dear Chris,

may thanks for your answer. I am still a bit new to macports, so I tried, but failed :) I have an older version of qca (2.1.0_2+qt4) that I activated using "port activate". And I also uninstalled the newer version of qca using port uninstall. Before reinstalling gis I uninstalled all qgis versions (after the upgrade attempt it did not work anyway with either of the versions) and did a port clean.

When reinstalling qgis, it is however catching the new qca version so that I am again running into this problem. Can you indicate how to tell him to use the older version?

Thanks in advance, Andreas

comment:5 Changed 2 years ago by EJFielding (Eric Fielding)

I am getting the same build failure trying to update from QGIS @2.18.0 which I have been using for a while to @2.18.0.1.

I tried deactivating my qca @2.1.0_4 and activating qca @2.1.0_3+qt4 (which required deactivating qgis and qca-ossl first). Then I tried to update qgis, but it still failed. MacPorts first reactivated qca-ossl @2.1.0_4, but then it seems to not find the correct qcaossl files. main.log excerpt:

:info:configure -- Found QScintilla2: /opt/local/libexec/qt4/lib/libqscintilla2.dylib (2.9.3)
:info:configure -- Found QCA: /opt/local/lib/libqca.dylib (2.1.0)
:info:configure CMake Error at cmake/QCAMacros.cmake:64 (message):
:info:configure   QCA OpenSSL plugin not found (run-time/unit-test dependency)
:info:configure Call Stack (most recent call first):
:info:configure   CMakeLists.txt:327 (FIND_QCAOSSL_PLUGIN_CPP)

Is there another hint we can try?

Thanks, ++Eric

comment:6 Changed 2 years ago by EJFielding (Eric Fielding)

Cc: EJFielding added

comment:7 Changed 2 years ago by Veence (Vincent)

I’m currently working on it, but I had to start over given the current Jasper woes and some other minor roadblocks. Expect something today.

comment:8 Changed 2 years ago by Veence (Vincent)

It’s been updated and should be fixed.

Please note that the buildbot failed to install any other version than the 10.12-based one, because of timeouts (internal errors I’ve no control over).

Last edited 2 years ago by Veence (Vincent) (previous) (diff)

comment:9 Changed 2 years ago by BuddyVolly

Dear Vincent, you know, in heaven, there must be a magical place for guys like you! For me it works. Thanks a lot, Andreas

comment:10 Changed 2 years ago by EJFielding (Eric Fielding)

I upgraded to the new @2_18_2_0 and it built with no problems after I cleaned it. Thanks!

comment:11 in reply to:  9 Changed 2 years ago by Veence (Vincent)

Resolution: fixed
Status: assignedclosed

Replying to BuddyVolly:

Dear Vincent, you know, in heaven, there must be a magical place for guys like you! For me it works.

I’m not sure I deserve a place in paradise for such a small thing, but I’m happy it made your day. Take care and merry Xmas to both.

Note: See TracTickets for help on using tickets.