Opened 2 years ago

Closed 2 months ago

#53173 closed defect (fixed)

py-pyobjc: fails to build on 10.6, uses 10.7 SDK; stdarg.h: No such file or directory

Reported by: mojca (Mojca Miklavec) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: snowleopard Cc:
Port: py-pyobjc

Description

It looks suspicious that the build is trying to use the 10.7 SDK:

/usr/bin/gcc-4.2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -arch i386 -I/opt/local/Library/Frameworks/Python.framework/Versions/3.6/include/python3.6m -c Modules/objc/OC_NSBundleHack.m -o build/temp.macosx-10.6-i386-3.6/Modules/objc/OC_NSBundleHack.o -DPyObjC_STRICT_DEBUGGING -DMACOSX -DPyObjC_BUILD_RELEASE=1006 -DMACOSX -g -fexceptions -Wall -Wstrict-prototypes -Wmissing-prototypes -Wformat=2 -W -Wpointer-arith -Wmissing-declarations -Wnested-externs -W -Wno-import -Wno-unknown-pragmas -Wshorten-64-to-32 -Ilibffi-src/include -Ilibffi-src/powerpc -isysroot /Developer/SDKs/MacOSX10.7.sdk
In file included from /opt/local/Library/Frameworks/Python.framework/Versions/3.6/include/python3.6m/Python.h:75,
                 from Modules/objc/pyobjc.h:11,
                 from Modules/objc/OC_NSBundleHack.m:1:
/opt/local/Library/Frameworks/Python.framework/Versions/3.6/include/python3.6m/bytearrayobject.h:9:20: error: stdarg.h: No such file or directory

Here's the full log.

Change History (5)

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

You are right that it is unexpected that the pyobjc build is trying to use the 10.7 SDK. I don't know if that's the cause of the problem, however.

The 10.6 buildbot machines do have the 10.7 SDK installed, because that was the only way to build libsdl2.

The pyobjc setup.py file runs /usr/bin/xcodebuild -version -sdk macosx Path to determine what SDK to use. On the 10.6 buildbot machines, this returns /Developer/SDKs/MacOSX10.7.sdk, presumably because it is the newest installed SDK.

comment:2 Changed 2 years ago by mojca (Mojca Miklavec)

Ah, that explains why I constantly get 10.(n+1) on my computer as well.

/usr/bin/xcodebuild -version -sdk macosx Path

returns the newer SDK for me as well.

I was looking at some links like http://stackoverflow.com/a/10330744/585897 which tend to suggest a broken installation of the toolchain.

comment:3 Changed 2 months ago by ryandesign (Ryan Schmidt)

Owner: set to ryandesign
Resolution: fixed
Status: newclosed

In 04d9fa05fd4660e87320b34888762f84019b7b64/macports-ports (master):

py-pyobjc: Update to 5.1.1

Closes: #56920

Specify which SDK to use.

Closes: #53173

comment:4 Changed 2 months ago by ryandesign (Ryan Schmidt)

Cc: ryandesign removed
Resolution: fixed
Status: closedreopened

Sigh, that didn't fix it. It's still finding a newer SDK if present.

comment:5 Changed 2 months ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

In 5029ed8ed8d2fd24d24a56867c347fa6bb6754c4/macports-ports (master):

py-pyobjc: *Really* use the right SDK

Closes: #53173

Note: See TracTickets for help on using tickets.