Opened 6 years ago

Closed 6 years ago

#53344 closed defect (duplicate)

wine, wine-devel: fails to run

Reported by: dershow Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: ryandesign (Ryan Schmidt), jyrkiwahlstedt
Port: wine, wine-devel

Description

I installed macports on a new machine (10.12.2) It is a fresh install of /opt/local. I have tried to install both wine and wine-devel, and each seems to install, but fail to run. I did delete ~/.wine to make sure that isn't interfering. With wine installed:

$ wine notepad
wine: created the configuration directory '/Users/adershowitz/.wine'
err:module:attach_process_dlls "gdi32.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\windows\\system32\\rundll32.exe" failed, status c0000005

wine-devel is a bit more verbose, but still doesn't explain the problem:

$ wine notepad
err:module:attach_process_dlls "gdi32.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\windows\\system32\\rundll32.exe" failed, status c0000005
err:module:DelayLoadFailureHook failed to delay load user32.dll.CreateDialogParamW
wine: Call from 0x7b427241 to unimplemented function user32.dll.CreateDialogParamW, aborting
wine: Unimplemented function user32.dll.CreateDialogParamW called at address 0x7b427241 (thread 000b), starting debugger...
err:seh:start_debugger Couldn't start debugger ("winedbg --auto 10 36") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
err:module:attach_process_dlls "gdi32.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\windows\\system32\\notepad.exe" failed, status c0000005

Any ideas what might be wrong? It seems like perhaps some necessary library is not installed? When I first did this macports install, I did have some issues related to +universal ports. But, I think that I got them worked out. I know that wine requires many ports to be 32bit (universal).

Change History (1)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Port: wine-devel added
Resolution: duplicate
Status: newclosed
Summary: Wine fails to runwine, wine-devel: fails to run

Duplicate of #53244.

Note: See TracTickets for help on using tickets.