Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#54288 closed defect (duplicate)

autogen @5.8.12 : Failed to configure autogen on ElCapitan

Reported by: NestorCerpa Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port:

Description

I have upgraded a Yosemite MacOS to ElCapitan and I was trying to install several ports from scratch. The problem is that for some of them I have an error when macports try to install autogen.

The main.log is attached

Attachments (3)

out_install_autogen (1.3 KB) - added by NestorCerpa 6 years ago.
Error message
main.log (18.6 KB) - added by NestorCerpa 6 years ago.
main.log
main2.log (8.0 KB) - added by NestorCerpa 6 years ago.
main2.log

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by NestorCerpa

Attachment: out_install_autogen added

Error message

Changed 6 years ago by NestorCerpa

Attachment: main.log added

main.log

comment:1 Changed 6 years ago by NestorCerpa

I have upgraded a Yosemite MacOS to ElCapitan and I was trying to install several ports from scratch. The problem is that for some of them I have an error when macports try to install autogen:

--->  Computing dependencies for autogen
--->  Cleaning autogen
--->  Scanning binaries for linking errors
--->  Found 2 broken files, matching files to ports
--->  Found 1 broken port, determining rebuild order
--->  Rebuilding in order
     autogen @5.18.12
--->  Computing dependencies for autogen
--->  Fetching distfiles for autogen
--->  Verifying checksums for autogen
--->  Extracting autogen
--->  Applying patches to autogen
--->  Configuring autogen
Error: Failed to configure autogen, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_autogen/autogen/work/autogen-5.18.12/config.log
Error: Failed to configure autogen: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_autogen/autogen/main.log for details.
Error: rev-upgrade failed: Error rebuilding autogen
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

I have the main.log attached.

comment:2 Changed 6 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

comment:3 in reply to:  2 Changed 6 years ago by NestorCerpa

Replying to jmroot:

I have followed the instructions in #54112. I've created a local portfile repository and created a sub-directory to copy the Portfile in it. In this sub-directory I've created another sub-directory named "files" where I've put the 2 patches. During fetch it says that one requested URL does not exist. I am attaching the log file main2.log.

--->  Computing dependencies for autogen
--->  Cleaning autogen
--->  Scanning binaries for linking errors
--->  Found 2 broken files, matching files to ports
--->  Found 1 broken port, determining rebuild order
You can always run 'port rev-upgrade' again to fix errors.
The following ports will be rebuilt: autogen @5.18.12
Continue? [Y/n]: Y
--->  Computing dependencies for autogen
--->  Cleaning autogen
--->  Scanning binaries for linking errors
--->  Found 2 broken files, matching files to ports
--->  Found 1 broken port, determining rebuild order
--->  Rebuilding in order
     autogen @5.18.12
--->  Computing dependencies for autogen
--->  Fetching distfiles for autogen
--->  Attempting to fetch yosemite-libtool.patch from https://distfiles.macports.org/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://lil.fr.distfiles.macports.org/autogen
--->  Attempting to fetch yosemite-libtool.patch from ftp://ftp.lip6.fr/pub/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://osl.no.distfiles.macports.org/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://nue.de.distfiles.macports.org/autogen
--->  Attempting to fetch yosemite-libtool.patch from ftp://ftp.funet.fi/pub/gnu/prep/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://ftp.gnu.org/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from ftp://ftp.gnu.org/old-gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://mirror.cc.columbia.edu/pub/software/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://mirrors.ibiblio.org/gnu/ftp/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://mirror.facebook.net/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://sea.us.distfiles.macports.org/macports/distfiles/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://kmq.jp.distfiles.macports.org/autogen
--->  Attempting to fetch yosemite-libtool.patch from https://pek.cn.distfiles.macports.org/macports/distfiles/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://jog.id.distfiles.macports.org/macports/distfiles/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://jnb.za.distfiles.macports.org/distfiles/autogen
--->  Attempting to fetch yosemite-libtool.patch from ftp://ftp.unicamp.br/pub/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://aarnet.au.distfiles.macports.org/pub/macports/distfiles/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://cjj.kr.distfiles.macports.org/autogen
--->  Attempting to fetch yosemite-libtool.patch from http://mirror.internode.on.net/pub/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://nou.nc.distfiles.macports.org/pub/macports/distfiles.macports.org/autogen
--->  Attempting to fetch yosemite-libtool.patch from ftp://ftp.informatik.hu-berlin.de/pub/gnu/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from ftp://ftp.kddlabs.co.jp/pub/gnu/gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from ftp://ftp.kddlabs.co.jp/pub/gnu/old-gnu/autogen/rel5.18.12
--->  Attempting to fetch yosemite-libtool.patch from http://her.gr.distfiles.macports.org/autogen
Error: Failed to fetch autogen: The requested URL returned error: 404 Not Found
Error: See /opt/local/var/macports/logs/_Users_Nestor_LocalPorts_devel_autogen/autogen/main.log for details.
Error: rev-upgrade failed: Error rebuilding autogen
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Changed 6 years ago by NestorCerpa

Attachment: main2.log added

main2.log

Note: See TracTickets for help on using tickets.