Opened 3 years ago

Last modified 4 months ago

#54785 assigned defect

R-app 1.68.1 fails to build on 10.13 beta 9 (high sierra) with Xcode 9.0 beta 6

Reported by: AP1010 Owned by: kjellpk (Kjell Konis)
Priority: Normal Milestone:
Component: ports Version: 2.4.1
Keywords: highsierra sierra xcode9 Cc: Schamschula (Marius Schamschula), adolfocorreia, Polyergic (Shad Sterling), razzfazz (Daniel Becker), todmorrison (Tod Morrison), fvaccari, dliessi (Davide Liessi)
Port: R-app

Description (last modified by mf2k (Frank Schima))

The build fails with:

** BUILD FAILED **

and numerous:

 '_tableView' is unavailable

Attachments (2)

main.log (1.3 MB) - added by AP1010 3 years ago.
Log file
sierra.main.log (1.2 MB) - added by raimue (Rainer Müller) 3 years ago.
Failed build on macOS 10.12 with Xcode 9

Change History (18)

Changed 3 years ago by AP1010

Attachment: main.log added

Log file

comment:1 Changed 3 years ago by kjellpk (Kjell Konis)

Maintainer here: this will almost certainly be fixed upstream once the R Core Team starts targeting High Sierra.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Cc: kjell.konis@… removed
Keywords: highsierra added
Owner: set to kjell.konis@…
Status: newassigned

In the future, please use WikiFormatting.

comment:3 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

Changed 3 years ago by raimue (Rainer Müller)

Attachment: sierra.main.log added

Failed build on macOS 10.12 with Xcode 9

comment:4 Changed 3 years ago by raimue (Rainer Müller)

Keywords: sierra xcode9 added

The build also fails on macOS 10.12, so Xcode 9 seems to be the culprit.

comment:5 Changed 3 years ago by Schamschula (Marius Schamschula)

Cc: Schamschula added

comment:6 Changed 3 years ago by adolfocorreia

Cc: adolfocorreia added

comment:7 Changed 3 years ago by Polyergic (Shad Sterling)

Cc: Polyergic added

comment:8 Changed 3 years ago by razzfazz (Daniel Becker)

Cc: razzfazz added

comment:9 Changed 3 years ago by todmorrison (Tod Morrison)

Cc: todmorrison added

comment:10 Changed 2 years ago by fvaccari

Cc: fvaccari added

comment:11 Changed 7 months ago by dliessi (Davide Liessi)

Cc: dliessi added

comment:12 Changed 7 months ago by dliessi (Davide Liessi)

Any news on this? The problem persists on my machine with

macOS 10.13.6 17G9016
Xcode 9.4.1 9F2000

comment:13 Changed 5 months ago by kencu (Ken)

It appears we are years out of date on this port, which is presently at 3.6.2 as of today

comment:14 in reply to:  13 Changed 5 months ago by reneeotten (Renee Otten)

Replying to kencu:

It appears we are years out of date on this port, which is presently at 3.6.2 as of today

I don't think that's completely accurate Ken. The port R is indeed at 3.6.2 and MacPorts has currently 3.6.1; here we're talking about the R-app port, which is indeed a bit out-of-date as the upstream version is 1.7.0. Of course, it doesn't hurt to update it and see if that solves the problem.

Last edited 5 months ago by reneeotten (Renee Otten) (previous) (diff)

comment:15 Changed 5 months ago by kencu (Ken)

I'm glad to hear that -- perhaps won't be as onerous as it seemed then.

comment:16 Changed 4 months ago by jmroot (Joshua Root)

Owner: changed from kjell.konis@… to kjellpk
Note: See TracTickets for help on using tickets.