Opened 3 years ago

Closed 8 days ago

#55719 closed defect (worksforme)

codeblocks @16.01-11098: error: expected expression

Reported by: ungur (Liviu Ungur) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: codeblocks

Description (last modified by mf2k (Frank Schima))

Installation of codeblocks @16.01-11098 failed.

--->  Computing dependencies for codeblocks
--->  Fetching archive for codeblocks
--->  Attempting to fetch codeblocks-16.01-11098_1+wxwidgets30.darwin_17.x86_64.tbz2 from http://lil.fr.packages.macports.org/codeblocks
--->  Attempting to fetch codeblocks-16.01-11098_1+wxwidgets30.darwin_17.x86_64.tbz2 from https://packages.macports.org/codeblocks
--->  Attempting to fetch codeblocks-16.01-11098_1+wxwidgets30.darwin_17.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/codeblocks
--->  Fetching distfiles for codeblocks
--->  Verifying checksums for codeblocks
--->  Extracting codeblocks
--->  Configuring codeblocks
--->  Building codeblocks
Error: Failed to build codeblocks: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_codeblocks/codeblocks/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port codeblocks failed

macOS version: 10.13.2 (17C205) High Sierra

Attachments (1)

main.log (792.7 KB) - added by ungur (Liviu Ungur) 3 years ago.
log file

Download all attachments as: .zip

Change History (10)

Changed 3 years ago by ungur (Liviu Ungur)

Attachment: main.log added

log file

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Keywords: compilation error removed
Owner: set to mojca
Port: @16.01-11098 removed
Status: newassigned

In the future, please use WikiFormatting.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 3 years ago by ryandesign (Ryan Schmidt)

Summary: Failed to build codeblocks @16.01-11098codeblocks @16.01-11098: error: expected expression

Confirmed with Xcode 9.2 on Sierra.

The code contains this line:

#define type(obj) ((obj)._type)

This conflicts with the way that the OS headers want to use type.

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Maybe the first thing we should try is to update codeblocks to 17.12.

comment:5 Changed 3 years ago by ryandesign (Ryan Schmidt)

codeblocks 17.12 doesn't contain an updated squirrel lib, so it should still have the problem, but squirrel lib has fixed it here; maybe we could backport it. Certainly, we should notify the developers of codeblocks to update their squirrel lib.

comment:6 Changed 3 years ago by mojca (Mojca Miklavec)

I would like to step out of the codeblocks maintainership. The authors are not really responsive, in particular not when it comes to Mac issues (since no developer has access to a mac), filed bug reports and even patches stay open for a very long time, the releases are scarse, compiling takes a lot of time and I don't even use the software myself. It was non-voluntarily assigned to me after doing a bunch of wxWidgets-related changes.

If anyone is willing to look into this, please take it over.

comment:7 Changed 3 years ago by mojca (Mojca Miklavec)

Owner: mojca deleted

comment:8 Changed 9 days ago by ungur (Liviu Ungur)

Please close this ticket. It is too old and this issue is not actual any longer.

comment:9 Changed 8 days ago by mf2k (Frank Schima)

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.