Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#55817 closed defect (duplicate)

osxfuse fails to install (High Sierra)

Reported by: dimalinux (Dmitry Holodov) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: osxfuse

Description

:info:build PhaseScriptExecution BridgeSupport\ Metadata build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh
:info:build     cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-431bdc5/framework
:info:build     /bin/sh -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-431bdc5/framework/build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh
:info:build /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': dlopen(/System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle, 0x0009): required dylib '@rpath/libclang.dylib' not found, needed by '/System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle'.  Did try: file not found '/Applications/Xcode.app/Contents/Developer/Toolchains/OSX10.13.xctoolchain/usr/lib/libclang.dylib', file not found '/usr/lib/libclang.dylib', file not found '/usr/local/lib/libclang.dylib' - /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle (LoadError)
:info:build     from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
:info:build     from /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.rb:6:in `<top (required)>'
:info:build     from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
:info:build     from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
:info:build     from /usr/bin/gen_bridge_metadata:65:in `<main>'
:info:build Command /bin/sh failed with exit code 1
:info:build ** BUILD FAILED **
:info:build The following build commands failed:
:info:build     PhaseScriptExecution BridgeSupport\ Metadata build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh

Attachments (1)

main.log (704.4 KB) - added by dimalinux (Dmitry Holodov) 3 years ago.

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by dimalinux (Dmitry Holodov)

Attachment: main.log added

comment:1 Changed 3 years ago by kencu (Ken)

Resolution: duplicate
Status: newclosed

duplicate of 54939

comment:2 Changed 3 years ago by kencu (Ken)

there is a workaround in that other ticket that you can use until Apple straightens this out.

comment:3 Changed 3 years ago by dimalinux (Dmitry Holodov)

Thanks, Ken! The workaround worked:

cd /Applications/Xcode.app/Contents/Developer/Toolchains
sudo ln -s XcodeDefault.xctoolchain OSX10.13.xctoolchain
sudo port install osxfuse
sudo rm OSX10.13.xctoolchain

comment:4 Changed 3 years ago by kencu (Ken)

Excellent! There is a new version of the toolchain in the works; should be released any time now. Hopefully fixed there.

comment:5 Changed 3 years ago by mf2k (Frank Schima)

Keywords: osxfuse removed
Note: See TracTickets for help on using tickets.