Opened 5 years ago

Closed 5 years ago

#56065 closed enhancement (fixed)

github portgroup: let port override livecheck version number regex

Reported by: ryandesign (Ryan Schmidt) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: github

Description

Many ports want to impose restrictions on the livecheck regex, such as not returning beta or RC versions. They currently do so by overriding livecheck.regex, which exposes too much internal implementation detail of the github portgroup into portfiles. Offer a new github portgroup option for overriding the default.

Change History (4)

comment:1 Changed 5 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

This seems to be a duplicate of #53940. At least they are trying to solve the same problem.

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: closedreopened

Not a duplicate.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

In 17f5c7000ffae20fe396789d21db3aa5b8ae6dda/macports-ports:

github-1.0.tcl: Add github.livecheck.regex

See: #56065

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Owner: set to ryandesign
Resolution: fixed
Status: reopenedclosed

In 9bbc6e46bc525b714dbea0d10970f29f18bcc7de/macports-ports:

Use github.livecheck.regex

Closes: #56065

Note: See TracTickets for help on using tickets.