Opened 3 years ago

Closed 3 years ago

#56118 closed defect (duplicate)

osxfuse: build failed with SIGTERM

Reported by: emeidi (Mario Aeby) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: osxfuse

Description

When trying to install osxfuse on macOS 10.13.3, I receive the following error message:

$ sudo port install osxfuse
--->  Computing dependencies for osxfuse
--->  Building osxfuse
Error: Failed to build osxfuse: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port osxfuse failed
$  sudo port clean osxfuse
--->  Cleaning osxfuse
$ sudo port install osxfuse
--->  Computing dependencies for osxfuse
--->  Fetching archive for osxfuse
--->  Attempting to fetch osxfuse-3.7.1_0.darwin_17.x86_64.tbz2 from https://packages.macports.org/osxfuse
--->  Attempting to fetch osxfuse-3.7.1_0.darwin_17.x86_64.tbz2 from http://nue.de.packages.macports.org/osxfuse
--->  Attempting to fetch osxfuse-3.7.1_0.darwin_17.x86_64.tbz2 from http://lil.fr.packages.macports.org/osxfuse
--->  Fetching distfiles for osxfuse
--->  Verifying checksums for osxfuse
--->  Extracting osxfuse
--->  Configuring osxfuse
--->  Building osxfuse
Error: Failed to build osxfuse: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port osxfuse failed

Attachments (1)

main.log (706.5 KB) - added by emeidi (Mario Aeby) 3 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by emeidi (Mario Aeby)

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log

comment:1 Changed 3 years ago by emeidi (Mario Aeby)

Important part of main.log:

:info:build Command /bin/sh failed with exit code 1
:info:build ** BUILD FAILED **
:info:build The following build commands failed:
:info:build 	PhaseScriptExecution BridgeSupport\ Metadata build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh
:info:build (1 failure)
:info:build T:framework          | [1;31mFailed to build target[0m
:info:build Terminated: 15
:info:build [0;37mReceived signal: SIGTERM[0m
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-431bdc5" && ./build.sh -t packagemanager -a build -v 5 --build-directory="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/work" -- -a x86_64 --framework-prefix="/opt/local" --fsbundle-prefix="/opt/local" --library-prefix="/opt/local" 
:info:build Killed by signal: 15
:error:build Failed to build osxfuse: command execution failed
:debug:build Error code: CHILDKILLED 1299 SIGTERM {software termination signal}
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:debug:build invalid command name "::ui_init"
:debug:build     while executing
:debug:build "::ui_init $priority $prefix $channels($priority) {*}$args"
:debug:build     ("uplevel" body line 2)
:debug:build     invoked from within
:debug:build "uplevel 1 $body"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log for details.

comment:2 Changed 3 years ago by raimue (Rainer Müller)

Cc: drkp removed
Resolution: duplicate
Status: newclosed
Summary: osxfuse fails to compile due to "invalid command name '::ui_init'"osxfuse: build failed with SIGTERM

Unfortunately you have to ignore the part about ::ui_init. This is only shown due to a bug (#55560) and not related to the build failure.

The real cause of the build failure is right above the part you quoted:

:info:build     /bin/sh -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-431bdc5/framework/build/OSXFUSE.build/Release/OSXFUSE.build/Script-28D525C40EA8076400B7CF7B.sh
:info:build /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': dlopen(/System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle, 0x0009): required dylib '@rpath/libclang.dylib' not found, needed by '/System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle'.  Did try: file not found '/Applications/Xcode.app/Contents/Developer/Toolchains/OSX10.13.xctoolchain/usr/lib/libclang.dylib', file not found '/usr/lib/libclang.dylib', file not found '/usr/local/lib/libclang.dylib' - /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle (LoadError)
:info:build 	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
:info:build 	from /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.rb:6:in `<top (required)>'
:info:build 	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
:info:build 	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
:info:build 	from /usr/bin/gen_bridge_metadata:65:in `<main>'

Duplicate of #54939.

Note: See TracTickets for help on using tickets.