Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#56157 closed defect (fixed)

ghostscript @9.23: doc symlink points into destroot; universal variant fails

Reported by: ryandesign (Ryan Schmidt) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: ghostscript

Description

$ sudo port -u upgrade ghostscript
--->  Computing dependencies for ghostscript
--->  Fetching archive for ghostscript
--->  Attempting to fetch ghostscript-9.23_0+universal+x11.darwin_16.i386-x86_64.tbz2 from https://packages.macports.org/ghostscript
--->  Fetching distfiles for ghostscript
--->  Verifying checksums for ghostscript
--->  Extracting ghostscript
--->  Applying patches to ghostscript
--->  Configuring ghostscript
--->  Building ghostscript
--->  Staging ghostscript into destroot
Error: Failed to destroot ghostscript: /opt/local/var/macports/build/_Users_rschmidt_macports_macports-ports-svn-trunk_print_ghostscript/ghostscript/work/destroot-i386//opt/local/share/ghostscript/9.23/doc and /opt/local/var/macports/build/_Users_rschmidt_macports_macports-ports-svn-trunk_print_ghostscript/ghostscript/work/destroot-x86_64//opt/local/share/ghostscript/9.23/doc point to different targets (can't merge them)
Error: See /opt/local/var/macports/logs/_Users_rschmidt_macports_macports-ports-svn-trunk_print_ghostscript/ghostscript/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Change History (3)

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

Owner: set to ryandesign
Status: newaccepted
Summary: ghostscript @9.23: universal variant failsghostscript @9.23: doc symlink points into destroot; universal variant fails

So the problem is that /opt/local/share/ghostscript/9.23/doc is a symlink to a path inside the destroot, which doesn't exist after installation.

The problem was introduced here because $(DESTDIR) was erroneously used on the source instead of the target. See also here where $(DESTDIR) was then added to the target but not removed from the source.

So this needs to be fixed by removing $(DESTDIR) from the source, the port needs to be revbumped, and the problem needs to be reported to the developers.

Last edited 2 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: acceptedclosed

In a1ded70c06f28648a6855c5410458689517242a8/macports-ports:

ghostscript: Fix doc symlink

Fixes destroot merging for universal variant.

Closes: #56157

comment:3 in reply to:  1 Changed 2 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign:

the problem needs to be reported to the developers.

https://bugs.ghostscript.com/show_bug.cgi?id=699157

Note: See TracTickets for help on using tickets.