Opened 3 years ago

Closed 2 years ago

#56190 closed defect (worksforme)

MoarVM @2018.03: Undefined symbols for architecture x86_64 (both 10.6.8 and 10.12.6)

Reported by: drennanelawar (Daniel Drennan ElAwar) Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: coke (Will Coleda)
Port: MoarVM

Description

I've had issues in the past with MoarVM on my Snow Leopard system, so I'm just stumped here because this happens on both my SL and MacBook Air systems, using Clang 3.9 on both. I can't find any information on _MVM_debugserver_init ... any input is greatly appreciated.

linking libmoar.dylib
linking moar
Undefined symbols for architecture x86_64:
  "_MVM_debugserver_init", referenced from:
      _main in main.o
ld: symbol(s) not found for architecture x86_64

Attachments (1)

main.log (51.7 KB) - added by drennanelawar (Daniel Drennan ElAwar) 3 years ago.
main.log

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by drennanelawar (Daniel Drennan ElAwar)

Attachment: main.log added

main.log

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: mojca removed
Owner: set to mojca
Status: newassigned
Summary: MoarVM: Undefined symbols for architecture x86_64 (both 10.6.8 and 10.12.6)MoarVM @2018.03: Undefined symbols for architecture x86_64 (both 10.6.8 and 10.12.6)

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Cc: coke added

comment:3 Changed 3 years ago by mojca (Mojca Miklavec)

Can you please open a ticket upstream or try to ask for help on IRC? The problem is that I cannot reproduce it myself, it built successfully on all our builders (10.5-10.13) and the upstream will probably ask you for further info (Makefiles etc.)

I don't know how to help you myself.

comment:4 Changed 2 years ago by mojca (Mojca Miklavec)

Ping. Can you please contact upstream and provide a link to upstream ticket here?

comment:5 Changed 2 years ago by drennanelawar (Daniel Drennan ElAwar)

Thanks for your help. I reported it upstream about a month ago; will add the link here now.

https://github.com/MoarVM/MoarVM/issues/832

Last edited 2 years ago by drennanelawar (Daniel Drennan ElAwar) (previous) (diff)

comment:6 Changed 2 years ago by drennanelawar (Daniel Drennan ElAwar)

On a whim (and out of frustration) I uninstalled rakudo, nqp, and MoarVM then reinstalled rakudo. Everything installed fine. Have no idea what the issue was, but this fixed it.

comment:7 Changed 2 years ago by mojca (Mojca Miklavec)

Resolution: worksforme
Status: assignedclosed

While it would still be interesting to figure out what the problem was, I'm now closing the ticket as we cannot reproduce it and it's no longer a problem for you.

Note: See TracTickets for help on using tickets.