Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#56246 closed defect (fixed)

libzip @1.5.0: Upgrade fails: error: use of undeclared identifier 'zip_buffer_fragment_t'

Reported by: gaming-hacker (G Alexander) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: libzip

Description

All, This source seems to be broken, I posted at github and libzip people blame zlib headers. I updated my version of zlib with all the appropriate PRs and still can't get this version of libzip to build.

Errors are :

libzip-1.5.0/regress/ziptool_regress.c:162:6: error: use of undeclared identifier 'zip_buffer_fragment_t'
:info:build             zip_buffer_fragment_t *fragments;
ziptool_regress.c:162:29: error: use of undeclared identifier 'fragments'; did you mean 'nfragments'?
:info:build             zip_buffer_fragment_t *fragments;
:info:build                                    ^~~~~~~~~
:info:build                                    nfragments

plus about 14 more repetitions of this error propagating through the build until eventually build stops at reaching error limit.

:info:build 2 warnings and 16 errors generated.

Attachments (1)

main.log (205.2 KB) - added by ryandesign (Ryan Schmidt) 2 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 2 years ago by raimue (Rainer Müller)

Cc: nomaintainer removed
Keywords: source broken removed

Cannot reproduce. libzip builds on my machine with and also without trace mode. Could you attach the main.log? macOS 10.12.6 16G1314 Xcode 9.2 9C40b

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added
Summary: libzip 1.5.0 still brokenlibzip @1.5.0: Upgrade fails: error: use of undeclared identifier 'zip_buffer_fragment_t'

The -I flags are in the wrong order, with -I/opt/local/include before the project's source directories, so upgrades from older versions can fail. I've attached my main.log.

Changed 2 years ago by ryandesign (Ryan Schmidt)

Attachment: main.log added

comment:3 Changed 2 years ago by gaming-hacker (G Alexander)

I backed out the Portfile to previous version of 1.3.2 and the logfile that @ryandesign added matches my attempted builds.

Does this mean a patch to the makefile/configure.in or is there a tcl wizard who can work some magic?

comment:4 Changed 2 years ago by kencu (Ken)

Until the CMake issues get sorted out, deactivating the previous libzip

sudo port deactivate libzip

and then installing the new version works.

comment:5 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign removed
Owner: set to ryandesign
Status: newaccepted

comment:6 Changed 2 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: acceptedclosed

In 56005de486d09c5472933e7d00b8c220235375c0/macports-ports:

libzip: Fix include path order

Fixes build failure when upgrading from older version.

Closes: #56246

comment:7 Changed 2 years ago by gaming-hacker (G Alexander)

The owner of this repo, nih-at, has fixed the cmake command and the next version 1.5.1 or 1.5.1a resolved this issue.

i cloned the repo and cherry picked the PR, built that version and no issues as a fresh portfile and as an upgraded portfile.

comment:8 Changed 2 years ago by ryandesign (Ryan Schmidt)

I know. I used their fix in my commit above.

Note: See TracTickets for help on using tickets.