Opened 2 years ago

Closed 2 years ago

#56266 closed defect (duplicate)

py-cartopy @0.15.1: Proj4 4.9.0 must be installed

Reported by: Chergnat Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: petr@macports.org

Description (last modified by ryandesign (Ryan Schmidt))

Hello,

The installation py-cartopy failed because the file wkt.pyc could not be read during execution.

I am using OS X El Capitan, 10.11.6 and Xcode 8.2.1.

I have tried to clean and reiterate the install, but not to avail.

I have checked that the file wkt.pyc did indeed exist. Here is the output of the ls -alt command:

-rw-r--r--  1 root  wheel  1626 Jan 29 08:07 /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/shapely/wkt.pyc

I am joining the py27-cartopy/main.log for details. Here is the most relevant excerpt:

  ...
  86 :info:build Executing:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-cartopy/py27-cartopy/work/cartopy-0.15.1" && /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 setup.py --no-user-cfg build
  87 :debug:build system:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-cartopy/py27-cartopy/work/cartopy-0.15.1" && /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 setup.py --no-user-cfg build
  88 :info:build Proj4 4.9.0 must be installed.
  89 :info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-cartopy/py27-cartopy/work/cartopy-0.15.1" && /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 setup.py --no-user-cfg build
  90 :info:build Exit code: 1
  91 :error:build Failed to build py27-cartopy: command execution failed
  92 :debug:build Error code: CHILDSTATUS 28767 1
  93 :debug:build Backtrace: command execution failed
  94 :debug:build     while executing
  95 :debug:build "system {*}$notty {*}$nice $fullcmdstring"
  96 :debug:build     invoked from within
  97 :debug:build "command_exec build"
  98 :debug:build     (procedure "portbuild::build_main" line 8)
  99 :debug:build     invoked from within
 100 :debug:build "$procedure $targetname"
 101 :debug:build could not read "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/shapely/wkt.pyc": no such file or directory
 102 :debug:build     while executing
 103 :debug:build "::file type $file"
 104 :error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-cartopy/py27-cartopy/main.log for details.

Some help would be greatly appreciated.

Attachments (1)

main.log (339.9 KB) - added by Chergnat 2 years ago.
py-cartopy installation failure main.log file

Download all attachments as: .zip

Change History (2)

Changed 2 years ago by Chergnat

Attachment: main.log added

py-cartopy installation failure main.log file

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: Chergnat removed
Description: modified (diff)
Keywords: elcapitan removed
Resolution: duplicate
Status: newclosed
Summary: py-cartopy installation failed, could not read wkt.pycpy-cartopy @0.15.1: Proj4 4.9.0 must be installed

Duplicate of #56150.

Note: See TracTickets for help on using tickets.