Opened 2 years ago

Closed 2 years ago

#56277 closed defect (fixed)

libvpx @1.7.0: Failed to configure libvpx: configure failure

Reported by: fairytalk Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc: kencu (Ken), jeremyhu (Jeremy Huddleston Sequoia)
Port: libvpx

Description (last modified by mf2k (Frank Schima))

Hi guys,

libvpx had been failing to configure for approximately a week. port is up to date (2.4.2), I'm running 10.13.4 on an encrypted, journaled, case-sensitive APFS share. Xcode is @9.3 (9E145). MacPorts is located in /opt/macports, next to homebrew (/opt/homebrew). port is ahead in the $PATH and hb has only ever been used for casks.

I get the following message when trying to build libvpx:

Error: Failed to configure libvpx, consult /opt/macports/var/macports/build/_opt_macports_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_multimedia_libvpx/libvpx/work/libvpx-1.7.0/config.log
Error: Failed to configure libvpx: configure failure: command execution failed
Error: See /opt/macports/var/macports/logs/_opt_macports_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_multimedia_libvpx/libvpx/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port libvpx failed

I checked ticket:56113 and it seemed to configure fine using this:

./configure --prefix=/opt/macports --enable-vp8 --enable-vp9 --enable-internal-stats --enable-pic --enable-postproc --enable-multithread --enable-runtime-cpu-detect --enable-experimental --enable-spatial-svc --enable-shared --disable-install-docs --disable-debug-libs --disable-examples --disable-unit-tests --target=x86_64-darwin-gcc

However I was unable to install it with make install, it returns make[1]: Nothing to be done for `install'. I guess I was overlooking something there.

Finally I ran sudo port -v install ld64 +ld64_xcode like kencu suggested, cleaned once more, and the install was successful. I'm not sure what was wrong but I'm submitting the ticket in hope that it might help other or dbevans. The suggested main.log and config.log are attached. Didn't find an install log for the eventual success, the screen messages were the usual though. Thanks guys.

Attachments (2)

main.log (120.6 KB) - added by fairytalk 2 years ago.
config.log (54.5 KB) - added by fairytalk 2 years ago.

Download all attachments as: .zip

Change History (11)

Changed 2 years ago by fairytalk

Attachment: main.log added

Changed 2 years ago by fairytalk

Attachment: config.log added

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Cc: dbevans removed
Description: modified (diff)
Keywords: highsierra x86_64 removed
Owner: set to dbevans
Status: newassigned

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: jeremyhu added

I guess this is to be expected, since the version of clang in the version of Xcode you have installed produces newer files than the version of ld64 in MacPorts is able to understand. I guess ld64 in MacPorts needs to be updated to Xcode 9.3's version thereof. (Currently, it provides Xcode 8.2.1's version.)

comment:3 Changed 2 years ago by ryandesign (Ryan Schmidt)

ld: unexpected token: !tapi-tbd-v3 file '/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.13.sdk/usr/lib/libpthread.tbd' for architecture x86_64

Or rather, macOS 10.13 and its SDK contain newer files than Xcode 8.2.1's ld is able to understand.

comment:4 Changed 2 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Use the +ld64_variant of ld64 as a workaround for now.

comment:5 Changed 2 years ago by cbean

Same issue running macport 2.4.3 on 10.12.6.

comment:6 Changed 2 years ago by kencu (Ken)

there is talk on the clang mailing list about Apple open-sourcing tapi , if I follow the politics of the correctly

comment:7 Changed 2 years ago by cbean

There was ld64 and ld64-latest installed:

port installed | grep ld
  ld64 @3_0 (active)
  ld64-latest @274.2_2+llvm50 (active)

I uninstalled ld64:

# umask 0022 && port -f uninstall ld64
--->  Unable to uninstall ld64 @3_0, the following ports depend on it:
--->  	clang-3.9 @3.9.1_8+analyzer+libstdcxx
Warning: Uninstall forced.  Proceeding despite dependencies.
--->  Deactivating ld64 @3_0
--->  Cleaning ld64
--->  Uninstalling ld64 @3_0
--->  Cleaning ld64

and then it built.

comment:8 Changed 2 years ago by cbean

Just for further info, since it seems to be a dependency issue caused by ffmpeg pulling in clang-3.9:

--->  Computing dependencies for ffmpeg-devel
--->  Dependencies to be installed: XviD fontconfig freetype libpng ossp-uuid perl5.26 gdbm readline fribidi glib2 gnutls gmp libidn2 libunistring 
texinfo help2man p5.26-locale-gettext libtasn1 nettle p11-kit curl-ca-bundle perl5 libxslt libxml2 lame libass yasm libbluray libfdk-aac libmodplug 
libogg libopus librsvg cairo libpixman cargo cmake curl libpsl python27 db48 python2_select libarchive lz4 lzo2 libcxx libuv rust llvm-6.0 llvm_select 
xar gdk-pixbuf2 gobject-introspection py27-mako py27-beaker py27-funcsigs py27-setuptools py27-markupsafe jasper jpeg shared-mime-info 
intltool gnome-common autoconf-archive p5.26-getopt-long p5.26-pathtools p5.26-scalar-list-utils p5.26-xml-parser p5.26-libwww-perl 
p5.26-encode-locale p5.26-file-listing p5.26-http-date p5.26-html-form p5.26-html-parser p5.26-html-tagset p5.26-http-message p5.26-io-html 
p5.26-lwp-mediatypes p5.26-try-tiny p5.26-capture-tiny p5.26-sub-name p5.26-devel-checkbin p5.26-extutils-makemaker 
p5.26-cpan-meta-requirements p5.26-extutils-manifest p5.26-uri p5.26-test-needs p5.26-http-cookies p5.26-http-daemon p5.26-http-negotiate 
p5.26-lwp-protocol-https p5.26-io-socket-ssl p5.26-io-socket-inet6 p5.26-io p5.26-socket6 p5.26-io-socket-ip p5.26-socket p5.26-mozilla-ca 
p5.26-net-libidn libidn p5.26-net-ssleay p5.26-test-exception p5.26-sub-uplevel p5.26-test-nowarnings p5.26-test-warn p5.26-net-http 
p5.26-test-fatal p5.26-test-requiresinternet p5.26-www-robotrules tiff libcroco pango harfbuzz graphite2 vala graphviz gd2 webp giflib gts libnetpbm 
libLASi urw-fonts libsdl2 libtheora libvorbis libvpx clang-3.9 clang_select ld64 ld64-latest libmacho-headers llvm-5.0 libomp llvm-3.9 nasm openjpeg 
jbigkit lcms2 samba3 popt soxr speex x264 x265

Last edited 2 years ago by cbean (previous) (diff)

comment:9 Changed 2 years ago by ken-cunningham-webuse

Resolution: fixed
Status: assignedclosed

In 5698d9483b44984a826d0f41154a4381b7957223/macports-ports (master):

ld64: default to +ld64_xcode on Xcode9+

ld64 does not understand tapi in the open-source
versions at present.

closes: #56843
closes: #53784
closes: #56398
closes: #56277
see: #56647
see: #54510
see: #54506
see: #53151

Note: See TracTickets for help on using tickets.