Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#56855 closed defect (duplicate)

clang-6.0-6.0.1_0 port broken

Reported by: vbychkoviak Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: Cc: larryv (Lawrence Velázquez), cjones051073 (Chris Jones)
Port: clang-6.0

Description

clang 6.0.1 port can't be upgraded.

2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch file cannot be found

--->  Computing dependencies for clang-6.0
--->  Fetching archive for clang-6.0
--->  Attempting to fetch clang-6.0-6.0.1_0+analyzer+libstdcxx.darwin_14.x86_64.tbz2 from https://packages.macports.org/clang-6.0
--->  Attempting to fetch clang-6.0-6.0.1_0+analyzer+libstdcxx.darwin_14.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/clang-6.0
--->  Attempting to fetch clang-6.0-6.0.1_0+analyzer+libstdcxx.darwin_14.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mirror/macports/packages/clang-6.0
--->  Fetching distfiles for clang-6.0
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from https://distfiles.macports.org/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://sea.us.distfiles.macports.org/macports/distfiles/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://ywg.ca.distfiles.macports.org/mirror/macports/distfiles/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://kmq.jp.distfiles.macports.org/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://cjj.kr.distfiles.macports.org/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://lil.fr.distfiles.macports.org/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://aarnet.au.distfiles.macports.org/pub/macports/distfiles/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from https://pek.cn.distfiles.macports.org/macports/distfiles/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://nue.de.distfiles.macports.org/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from https://sha.cn.distfiles.macports.org/macports/distfiles/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://jog.id.distfiles.macports.org/macports/distfiles/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://nou.nc.distfiles.macports.org/pub/macports/distfiles.macports.org/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://jnb.za.distfiles.macports.org/distfiles/llvm
--->  Attempting to fetch 2001-xray-Define-O_CLOEXEC-for-older-SDKs-that-don-t-have.patch from http://llvm.org/releases/6.0.1
Error: Failed to fetch clang-6.0: The requested URL returned error: 404 Not Found
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-6.0/clang-6.0/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

problem can be related to commit c3f687bb5590f70197f0fbb52cb2d9f48a459eab

macports: 2.5.3 os: OSX 10.10.5 Yosemite

Change History (3)

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Cc: larryv added
Owner: set to jeremyhu
Port: clang-6.0 added
Status: newassigned

In the future, please fill in the Port field and Cc the port maintainer(s) to Cc (port info --maintainers clang-6.0), if any.

comment:2 Changed 2 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: assignedclosed

Duplicate of #56854.

comment:3 Changed 2 years ago by cjones051073 (Chris Jones)

Cc: cjones051073 added
Note: See TracTickets for help on using tickets.