Opened 2 years ago

Closed 2 years ago

#57201 closed defect (invalid)

Build failure of pstoedit due to poppler 0.69.0

Reported by: thyAnger Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: Cc: dbevans (David B. Evans), drkp (Dan Ports), mojca (Mojca Miklavec)
Port: pstoedit texlive-bin poppler

Description

I tried to install octave but when building pstoedit (it is a dependency) I get error. Please see the attachment for log. Here iMac retina 5K, 27-inch, 2017, with os 10.13.6

Attachments (1)

main.log (114.3 KB) - added by thyAnger 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by thyAnger

Attachment: main.log added

comment:1 Changed 2 years ago by Schamschula (Marius Schamschula)

Keywords: octave removed
Summary: Can't install octave due to pstoedit fail during buildBuild failure of pstoedit due to poppler 0.69.0

The log file shows that pstoedit failed to build because it couldn't find libpoppler

dyld: Library not loaded: /opt/local/lib/libpoppler.79.dylib

Have you run port selfupdate or port sync?

comment:2 Changed 2 years ago by Schamschula (Marius Schamschula)

Keywords: pstoedit removed
Port: poppler pstoedit added

comment:3 Changed 2 years ago by jmroot (Joshua Root)

Cc: dbevans added

comment:4 Changed 2 years ago by jmroot (Joshua Root)

Cc: drkp added
Port: texlive-bin added

Specifically it's pdflatex failing to run, which again suggests you need to selfupdate to get the latest changes to texlive-bin.

Referenced from: /opt/local/bin/pdflatex

comment:5 Changed 2 years ago by thyAnger

Ok it works after selfupdate.

comment:6 Changed 2 years ago by mojca (Mojca Miklavec)

Cc: mojca added

comment:7 Changed 2 years ago by mojca (Mojca Miklavec)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.