Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#57204 closed defect (fixed)

aquaterm build failure under macOS Mojave

Reported by: murrayE Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: g5pw (Aljaž Srebrnič)
Port: aquaterm

Description

With MacPorts 2.5.4 under macOS 10.14 (Mojave), I'm migrating MacPorts' ports. Command "sudo port install aquaterm" gives error "Failed to build aquaterm: command execution failed".

From the attached main.log:

:info:build Build settings from command line:
:info:build     ARCHS = x86_64
:info:build     CLANG_CXX_LIBRARY = libc++
:info:build     GCC_VERSION = com.apple.compilers.llvm.clang.1_0
:info:build     LOCAL_APPS_DIR = /Applications/MacPorts
:info:build     LOCAL_FRAMEWORKS_DIR = /opt/local/Library/Frameworks
:info:build     MACOSX_DEPLOYMENT_TARGET = 10.14
:info:build     OBJROOT = /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/build/
:info:build     SDKROOT = /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk
:info:build     SYMROOT = /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/build/
:info:build 2018-09-30 15:02:24.439 xcodebuild[19895:1436075] [MT] IDELogStore: Failed to open log store at /opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok/Logs/Build
:info:build 2018-09-30 15:02:24.439 xcodebuild[19895:1436075] [MT] IDELogStore: Failed to open Build log store: Error Domain=IDEFoundationErrorDomain Code=1 "Unable to create log store directory at '/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok/Logs/Build': (513) You don’t have permission to save the file “Build” in the folder “Logs”." UserInfo={NSLocalizedDescription=Unable to create log store directory at '/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok/Logs/Build': (513) You don’t have permission to save the file “Build” in the folder “Logs”.}. User info: {
:info:build     NSLocalizedDescription = "Unable to create log store directory at '/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok/Logs/Build': (513) You don\U2019t have permission to save the file \U201cBuild\U201d in the folder \U201cLogs\U201d.";
:info:build }.
:info:build 2018-09-30 15:02:24.446 xcodebuild[19895:1436075] [MT] IDELogStore: Failed to open log store at /opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok/Logs/Test
:info:build 2018-09-30 15:02:24.446 xcodebuild[19895:1436075] [MT] IDELogStore: Failed to open Test log store: Error Domain=IDEFoundationErrorDomain Code=1 "Unable to create log store directory at '/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok/Logs/Test': (513) You don’t have permission to save the file “Test” in the folder “Logs”." UserInfo={NSLocalizedDescription=Unable to create log store directory at '/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok/Logs/Test': (513) You don’t have permission to save the file “Test” in the folder “Logs”.}. User info: {
:info:build     NSLocalizedDescription = "Unable to create log store directory at '/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok/Logs/Test': (513) You don\U2019t have permission to save the file \U201cTest\U201d in the folder \U201cLogs\U201d.";
:info:build }.
:info:build 2018-09-30 15:02:24.450 xcodebuild[19895:1436085] Error Domain=com.apple.CoreSimulator.SimError Code=159 "Unable to determine SimDeviceSet, set_path=/opt/local/var/macports/home/Library/Developer/CoreSimulator/Devices" UserInfo={NSLocalizedDescription=Unable to determine SimDeviceSet, set_path=/opt/local/var/macports/home/Library/Developer/CoreSimulator/Devices, NSUnderlyingError=0x7febfe7d9b40 {Error Domain=NSPOSIXErrorDomain Code=12 "Cannot allocate memory" UserInfo={NSLocalizedFailureReason=Allocation or initialization failed., NSLocalizedDescription=Failed to initialize simulator device set.}}}
:info:build 2018-09-30 15:02:24.450 xcodebuild[19895:1436085]  iOSSimulator: [SimServiceContext defaultDeviceSetWithError:] returned nil (Error Domain=com.apple.CoreSimulator.SimError Code=159 "Failed to initialize simulator device set." UserInfo={NSLocalizedFailureReason=Failed to subscribe to notifications from CoreSimulatorService., NSLocalizedDescription=Failed to initialize simulator device set., NSUnderlyingError=0x7febfe7da010 {Error Domain=com.apple.CoreSimulator.SimError Code=159 "Unable to determine SimDeviceSet, set_path=/opt/local/var/macports/home/Library/Developer/CoreSimulator/Devices" UserInfo={NSLocalizedDescription=Unable to determine SimDeviceSet, set_path=/opt/local/var/macports/home/Library/Developer/CoreSimulator/Devices, NSUnderlyingError=0x7febfe7d9b40 {Error Domain=NSPOSIXErrorDomain Code=12 "Cannot allocate memory" UserInfo={NSLocalizedFailureReason=Allocation or initialization failed., NSLocalizedDescription=Failed to initialize simulator device set.}}}}}). Simulator device support disabled.
:info:build 2018-09-30 15:02:24.966 xcodebuild[19895:1436075] [MT] DVTAssertions: Warning in /Library/Caches/com.apple.xbs/Sources/IDEFrameworks_Fall2018/IDEFrameworks-14320.25/IDEFoundation/Buildables/IDEWorkspaceArena.m:1146
:info:build Details:  Failed to create workspace arena at <DVTFilePath:0x7febfe7d5260:'/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok'>: Error Domain=NSCocoaErrorDomain Code=513 "You don’t have permission to save the file “AquaTerm-ecxqruonjognuddgvymjlzmexuok” in the folder “DerivedData”." UserInfo={NSFilePath=/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/AquaTerm-ecxqruonjognuddgvymjlzmexuok, NSUnderlyingError=0x7fec034c4e20 {Error Domain=NSPOSIXErrorDomain Code=1 "Operation not permitted"}}
:info:build Object:   <IDEWorkspaceArena: 0x7febfe7c4250>
:info:build Method:   -createWorkspaceArenaFolderIfNecessary
:info:build Thread:   <NSThread: 0x7febfe705aa0>{number = 1, name = main}
:info:build Please file a bug at https://bugreport.apple.com with this warning message and any useful information you can provide.
:info:build note: Using new build system
:info:build note: Planning build
:info:build note: Constructing build description
:info:build Build system information
:info:build warning: Traditional headermap style is no longer supported; please migrate to using separate headermaps and set 'ALWAYS_SEARCH_USER_PATHS' to NO. (in target 'AQTFwk')
:info:build Build system information
:info:build warning: Traditional headermap style is no longer supported; please migrate to using separate headermaps and set 'ALWAYS_SEARCH_USER_PATHS' to NO. (in target 'AquaTerm')
:info:build Build system information
:info:build warning: duplicate output file '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/build/Default/AquaTerm.app/Contents/Resources/help.html' on task: PBXCp /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/Help/help.html /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/build/Default/AquaTerm.app/Contents/Resources/help.html (in target 'AquaTerm')
:info:build Build system information
:info:build error: Multiple commands produce '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/build/Default/AquaTerm.app/Contents/Resources/help.html':
:info:build 1) Target 'AquaTerm' (project 'AquaTerm') has copy command from '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/Help/help.html' to '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/build/Default/AquaTerm.app/Contents/Resources/help.html'
:info:build 2) Target 'AquaTerm' (project 'AquaTerm') has copy command from '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/Help/help.html' to '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/build/Default/AquaTerm.app/Contents/Resources/help.html'
:info:build ** BUILD FAILED **
:info:build Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm" && /usr/bin/xcodebuild  -target "AquaTerm" -configuration Default build   OBJROOT="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/build/" SYMROOT="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_aquaterm/aquaterm/work/AquaTerm-1.1.1/aquaterm/build/" MACOSX_DEPLOYMENT_TARGET=10.14 ARCHS=x86_64 SDKROOT="/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk" GCC_VERSION=com.apple.compilers.llvm.clang.1_0 CLANG_CXX_LIBRARY="libc++" LOCAL_APPS_DIR=/Applications/MacPorts LOCAL_FRAMEWORKS_DIR=/opt/local/Library/Frameworks
:info:build Exit code: 65

Attachments (1)

main.log (26.8 KB) - added by murrayE 3 years ago.
main.log

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by murrayE

Attachment: main.log added

main.log

comment:1 Changed 3 years ago by murrayE

Note: This is with released Mojave, Xcode 10.0 and corresponding command-line tools.

comment:2 Changed 3 years ago by mojca (Mojca Miklavec)

Can you please try to update to the latest version? I assume that https://github.com/macports/macports-ports/pull/2669 should have fixed this issue and that this is a duplicate of #56895.

comment:3 Changed 3 years ago by mojca (Mojca Miklavec)

Cc: ] added; mojca removed
Owner: set to mojca
Status: newassigned
Version: 2.5.3

comment:4 Changed 3 years ago by mojca (Mojca Miklavec)

Cc: ] removed

comment:5 in reply to:  3 Changed 3 years ago by murrayE

Replying to mojca: Yes, now OK after latest port sync, now using aquaterm-1.1.1_0

comment:6 Changed 3 years ago by mojca (Mojca Miklavec)

Resolution: fixed
Status: assignedclosed

comment:7 Changed 3 years ago by mojca (Mojca Miklavec)

OK, thank you very much for the report and confirmation about the fix.

Note: See TracTickets for help on using tickets.