Opened 22 months ago

Closed 22 months ago

Last modified 20 months ago

#57223 closed defect (duplicate)

xhyve @20180530: Build fails on macOS Mojave (10.14)

Reported by: mtn88 (Max) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version:
Keywords: xcode10 Cc:
Port: xhyve

Description

Please see attached log file

Attachments (1)

xhyve-main.log (65.9 KB) - added by mtn88 (Max) 22 months ago.

Download all attachments as: .zip

Change History (6)

Changed 22 months ago by mtn88 (Max)

Attachment: xhyve-main.log added

comment:1 Changed 22 months ago by mf2k (Frank Schima)

In the future, please add the port maintainer(s) to Cc (port info --maintainers xhyve), if any.

comment:2 Changed 22 months ago by mf2k (Frank Schima)

Owner: set to jeremyhu
Status: newassigned

comment:3 Changed 22 months ago by mf2k (Frank Schima)

Keywords: xcode10 added

Looks to be an issue with the new build system in Xcode 10.

:info:build Details:  Failed to create workspace arena at <DVTFilePath:0x7fcf7028d330:'/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/xhyve-dpgiavvgrmrnanatotyyzetsqoak'>: Error Domain=NSCocoaErrorDomain Code=513 "You don’t have permission to save the file “xhyve-dpgiavvgrmrnanatotyyzetsqoak” in the folder “DerivedData”." UserInfo={NSFilePath=/opt/local/var/macports/home/Library/Developer/Xcode/DerivedData/xhyve-dpgiavvgrmrnanatotyyzetsqoak, NSUnderlyingError=0x7fcf702a1420 {Error Domain=NSPOSIXErrorDomain Code=1 "Operation not permitted"}}

comment:4 Changed 22 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #57137.

comment:5 Changed 20 months ago by jeremyhu (Jeremy Huddleston Sequoia)

Fixed in #57674.

Note: See TracTickets for help on using tickets.