Opened 2 years ago

Closed 2 years ago

#57254 closed defect (fixed)

squid3 fails to configure on 10.14

Reported by: essandess (Steve Smith) Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: mojave Cc:
Port: squid3

Description

squid3 fails to configure on 10.14.

Fresh Macports install, clean /opt/local directory:

sudo port selfupdate
sudo port -puN install squid3

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_net_squid3/squid3/main.l

:error:configure Failed to configure squid3, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_net_squid3/squid3/work/squid-3.5.28/config.log

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_net_squid3/squid3/work/squid-3.5.28/config.log

configure:5040: /usr/bin/clang -V >&5
clang: error: argument to '-V' is missing (expected 1 value)

This looks like a standard (old) issue with Xcode pointing gcc to /usr/bin/clang. For example, https://stackoverflow.com/questions/20132805/configure-error-with-mac-os-x-10-8-5-xcode-5-0-2-clang-error-argument-to-v

I tried unsuccessfully to install macports gcc-8 and clang-7.0 to fix this, but ran into similar issues.

Attachments (1)

config.log (479.9 KB) - added by essandess (Steve Smith) 2 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 2 years ago by jmroot (Joshua Root)

Cc: jmr@… removed
Keywords: mojave added
Owner: set to jmroot
Status: newaccepted

Could you attach the config.log please?

Changed 2 years ago by essandess (Steve Smith)

Attachment: config.log added

comment:2 Changed 2 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: acceptedclosed

In d397b7bc19f7b61bc6092c8091493d2e7b652ae6/macports-ports (master):

squid3: fix build with no /usr/include

Closes: #57254

Note: See TracTickets for help on using tickets.