Opened 2 years ago

Closed 2 years ago

#57267 closed defect (duplicate)

MacVim: error: cannot find protocol declaration for 'NSTouchBarDelegate'

Reported by: ryandesign (Ryan Schmidt) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: MacVim

Description

MacVim fails to build on 10.9, and presumably any other macOS version using an SDK before 10.12.2, due to use of touchbar code:

In file included from /opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_editors_MacVim/MacVim/work/macvim-151/src/MacVim/MMTextView.m:26:
/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_editors_MacVim/MacVim/work/macvim-151/src/MacVim/MMVimController.h:22:7: error: cannot find protocol declaration for 'NSTouchBarDelegate'; did you mean 'NSToolbarDelegate'?
    , NSTouchBarDelegate
      ^~~~~~~~~~~~~~~~~~
      NSToolbarDelegate

Touchbar code should be wrapped in availability macros to hide it from macOS 10.12.1 and earlier SDKs.

Change History (3)

comment:1 Changed 2 years ago by kencu (Ken)

IF we can get ld64 to accept the TAPI constructs in the newer SDKs, we could also get these older systems to build against the 10.12 or 10.13 SDK and fix this the "Apple" way...

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Yes, once I add the MacOSX.sdk port we can try that.

comment:3 Changed 2 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: assignedclosed

Duplicate of #57091.

Note: See TracTickets for help on using tickets.