Opened 4 years ago

Closed 4 years ago

#57347 closed defect (fixed)

unison +aqua does not build on Mojave

Reported by: miguelbarao (MB) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: xcode10 Cc: miguel.barao@…, inyeollee, MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: unison

Description

The port unison does not build with the default +aqua variant. I can only install it disabling the aqua variant port install unison -aqua.

Attachments (1)

main.log (35.0 KB) - added by miguelbarao (MB) 4 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

Keywords: mojave added; unison aqua removed

Could you attach a main.log file showing what the problem is?

Changed 4 years ago by miguelbarao (MB)

Attachment: main.log added

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Keywords: xcode10 added; mojave removed

This appears to be a problem with the new build system used by Xcode 10.

:info:build note: Using new build system
:info:build 2018-10-11 15:04:55.143 xcodebuild[34941:85697] unexpected response: ErrorResponse(description: "unknown error while handling message: missingWorkspaceContext")
:info:build error: Build service could not start build operation: internal error: failed to send the system info to the build service
:info:build ** BUILD FAILED **

comment:3 Changed 4 years ago by inyeollee

Cc: inyeollee added

comment:4 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added

comment:5 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Owner: set to MarcusCalhoun-Lopez
Resolution: fixed
Status: newclosed

In bafa2f17fb162389454b74cc432c60253e949269/macports-ports (master):

unison: fix build for Xcode>=10.0

Fixes #57347

Note: See TracTickets for help on using tickets.