Opened 2 years ago

Last modified 2 years ago

#57941 assigned defect

Unable to install py27-pyqt4

Reported by: josefaffourtit Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: eborisch (Eric A. Borisch)
Port: py-pyqt4

Description (last modified by mf2k (Frank Schima))

Log file attached.

I've tried:

sudo port clean --all py27-pyqt4

sudo port selfupdate

sudo port install py27-pyqt4

To no avail. I am trying to install sciDAVis for academic purposes.

Attachments (1)

main.log (353.3 KB) - added by josefaffourtit 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by josefaffourtit

Attachment: main.log added

comment:1 Changed 2 years ago by mf2k (Frank Schima)

In the future, please fill in the Port field.

comment:2 Changed 2 years ago by mf2k (Frank Schima)

Cc: michaelld removed
Description: modified (diff)
Owner: set to michaelld
Port: py-pyqt4 added
Status: newassigned

comment:3 Changed 2 years ago by mf2k (Frank Schima)

Error appears to be:

:info:build ar cq libqpygui.a moc_qpytextobject.o
:info:build /opt/local/bin/ranlib: object: libqpygui.a(moc_qpytextobject.o) malformed object (unknown load command 1)
:info:build ar: internal ranlib command failed

comment:4 in reply to:  3 Changed 2 years ago by josefaffourtit

Replying to mf2k:

Error appears to be:

:info:build ar cq libqpygui.a moc_qpytextobject.o
:info:build /opt/local/bin/ranlib: object: libqpygui.a(moc_qpytextobject.o) malformed object (unknown load command 1)
:info:build ar: internal ranlib command failed

Any thoughts on a resolution or workaround? I'm not very familiar with MacPorts.

comment:5 Changed 2 years ago by michaelld (Michael Dickens)

What does the following return for you:

port installed cctools

comment:6 Changed 2 years ago by michaelld (Michael Dickens)

My installed cctools is "cctools @921_0+llvm70", and it works on 10.14.2 latest to build py27-pyqt4.

comment:7 Changed 2 years ago by michaelld (Michael Dickens)

Thus you can try this if you want to; it might work:

sudo port clean py27-pyqt4
sudo port -f deactivate cctools
sudo port install py27-pyqt4
sudo port activate cctools

Or you can try to reinstall cctools to get the current default (+llvm70) ... either might work.

Note: See TracTickets for help on using tickets.