#58006 closed defect (fixed)

MPlayer @1.3.0_3: error: invalid output constraint '=o' in asm

Reported by: kencu (Ken) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version:
Keywords: snowleopard Cc:
Port: mplayer

Description

The current blacklisting in the mplayer port leads unfortunately to an attempt to build it with the default clang on 10.6.8, which fails miserably on the assembly.

:info:build libmpcodecs/vf_fspp.c:1598:48: error: invalid output constraint '=o' in asm
:info:build         : "+S"(data), "+D"(output), "+c"(cnt), "=o"(temps)
:info:build                                                ^
:info:build libmpcodecs/vf_fspp.c:1871:57: error: invalid output constraint '=o' in asm
:info:build         : "+S"(workspace), "+D"(output_adr), "+c"(cnt), "=o"(temps)
:info:build                                                         ^
:info:build libmpcodecs/vf_fspp.c:2118:48: error: invalid output constraint '=o' in asm
:info:build         : "+S"(pixels), "+D"(data), "+c"(cnt), "=o"(temps), "=o"(temps[1])
:info:build                                                ^

forcing the build to something newer (I used clang-5.0) works nicely.

Attachments (1)

main.log (271.3 KB) - added by kencu (Ken) 21 months ago.

Download all attachments as: .zip

Change History (4)

Changed 21 months ago by kencu (Ken)

Attachment: main.log added

comment:1 Changed 21 months ago by kencu (Ken)

So this above report comes from a user on the mailing list. However, I just built MPlayer on my 10.6.8 VM (x86_64) and it built fine on there with the default compilers.

So either it's an i386 thing (TBA), or the user has some beagles in his setup somewhere...

comment:2 Changed 21 months ago by kencu (Ken)

This turns out to be a duplicate of this ancient ticket 42743 so I think we just have to sort out the blacklisting / fallbacks a bit...

comment:3 Changed 21 months ago by kencu (Ken)

Resolution: fixed
Status: assignedclosed

I believe this has been fixed by the addition blacklisting added today. At least, mplayer and mplayer-devel build without intervention on the 32bit and 64bit VMs I have here. Please reopen if there are further troubles with this.

Note: See TracTickets for help on using tickets.