Opened 2 years ago

Closed 22 months ago

#58146 closed defect (duplicate)

HandBrakeCLI fails to build on macOS Mojave 10.14

Reported by: rncole Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc: Kyshman (Tony Kinyua)
Port: HandBrakeCLI

Description (last modified by mf2k (Frank Schima))

HandBrakeCLI fails to build.

:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_multimedia_HandBrake/HandBrakeCLI/work/HandBrake-0.10.0" && ./configure --prefix=/opt/local --arch=x86_64 --curl=false --fetch=curl --gcc='/usr/bin/clang' --verbose --xcode-config=osx1014.x86_64 --xcode-driver=terminal APPLICATIONS_DIR='/Applications/MacPorts' BUILD.jobs=4 CCACHE=no GCC_VERSION=com.apple.compilers.llvm.clang.1_0 
:info:configure Exit code: 2
:error:configure Failed to configure HandBrakeCLI: configure failure: command execution failed

/\/\/\/\ Running the configure command above manually results in the following:

configure.py: error: invalid xcconfig: osx1014.x86_64 (choose from: native none osx1010.i386 osx1010.x86_64 osx106.i386 osx106.x86_64 osx107.i386 osx107.x86_64 osx108.i386 osx108.x86_64 osx109.i386 osx109.x86_64 supplemental)

Change History (7)

comment:1 Changed 2 years ago by kencu (Ken)

Hopefully they have fixed this upstream, and we can use some newer release.

comment:2 Changed 2 years ago by mf2k (Frank Schima)

In the future, please use WikiFormatting and add the port maintainer(s) to Cc (port info --maintainers HandBrakeCLI), if any.

comment:3 Changed 2 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: Mojave removed
Owner: set to larryv
Status: newassigned
Type: updatedefect

comment:4 Changed 2 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: assignedclosed

Duplicate of #49129.

comment:5 Changed 22 months ago by Kyshman (Tony Kinyua)

Resolution: duplicate
Status: closedreopened

This still is occurring on Mojave 10.14.5

Ports version: MacPorts 2.5.4

HandbrakeCLI port version: HandBrakeCLI @0.10.0

I can provide the log file if needed.

comment:6 Changed 22 months ago by Kyshman (Tony Kinyua)

Cc: Kyshman added

comment:7 Changed 22 months ago by mf2k (Frank Schima)

Resolution: duplicate
Status: reopenedclosed

Please do not re-open duplicate tickets because that is still the case.

Note: See TracTickets for help on using tickets.