Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#58580 closed defect (fixed)

Remove mirror sea.us.{rsync,distfiles,packages}.macports.org after being out-of-date for almost a year

Reported by: raimue (Rainer Müller) Owned by: admin@…
Priority: Normal Milestone:
Component: server/hosting Version:
Keywords: Cc:
Port:

Description (last modified by raimue (Rainer Müller))

The mirror in Seattle, USA operated by PNNL has not been updated for almost a year. At first no administrative contact was reachable, but later it was confirmed the server in question was decommissioned (although still reachable?).

While missing distfiles or packages will be skipped, using the ports tree from this mirror over rsync is a problem. However, also for distfiles and packages, this mirror will not help users if it is not updated as it leads to unnecessary download delays. We should therefore remove it from our mirror rotation.

Original report: https://lists.macports.org/pipermail/macports-users/2019-June/046832.html

Change History (7)

comment:1 Changed 2 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

In 28458fabcf75763d4cb60650e5cc0c0892610e17/macports-ports (master):

mirrors: Remove sea.us.{distfiles,packages}.macports.org

The mirror has been stale for almost a year.

Closes: #58580

comment:2 Changed 2 years ago by raimue (Rainer Müller)

Description: modified (diff)

comment:3 Changed 2 years ago by raimue (Rainer Müller)

Description: modified (diff)
Resolution: fixed
Status: closedreopened

comment:4 Changed 2 years ago by raimue (Rainer Müller)

I have not yet removed the DNS records in order not to immediately break downloads for those that still have it listed in their ports tree, but will follow through with this later.

comment:5 Changed 2 years ago by ryandesign (Ryan Schmidt)

If anyone is still syncing from that server, it's because they haven't noticed it's not updating. In which case, removing the DNS records would be a good way to get those users to notice.

comment:6 Changed 2 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: reopenedclosed

I removed sea.us.{distfiles,packages,rsync}.macports.org from DNS.

comment:7 Changed 2 years ago by raimue (Rainer Müller)

Description: modified (diff)
Note: See TracTickets for help on using tickets.