#58602 closed defect (fixed)

pstoedit @3.74: error: call to 'abs' is ambiguous

Reported by: dbl001 (dbl) Owned by: dliessi (Davide Liessi)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc: tehcog (tehcog), Blokkendoos (Johan), dliessi (Davide Liessi)
Port: pstoedit

Description

OS X 10.11.6

$ sudo port upgrade outdated
Password:
--->  Computing dependencies for texlive-bin-extra
--->  Fetching archive for texlive-bin-extra
--->  Attempting to fetch texlive-bin-extra-50853_1+doc.darwin_15.noarch.tbz2 from http://aus.us.packages.macports.org/macports/packages/texlive-bin-extra
--->  Attempting to fetch texlive-bin-extra-50853_1+doc.darwin_15.noarch.tbz2.rmd160 from http://aus.us.packages.macports.org/macports/packages/texlive-bin-extra
--->  Installing texlive-bin-extra @50853_1+doc
--->  Activating texlive-bin-extra @50853_1+doc
--->  Cleaning texlive-bin-extra
--->  Computing dependencies for pstoedit
--->  Fetching archive for pstoedit
--->  Attempting to fetch pstoedit-3.74_0.darwin_15.x86_64.tbz2 from http://aus.us.packages.macports.org/macports/packages/pstoedit
--->  Attempting to fetch pstoedit-3.74_0.darwin_15.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mirror/macports/packages/pstoedit
--->  Attempting to fetch pstoedit-3.74_0.darwin_15.x86_64.tbz2 from https://packages.macports.org/pstoedit
--->  Fetching distfiles for pstoedit
--->  Attempting to fetch pstoedit-3.74.tar.gz from http://superb-sea2.dl.sourceforge.net/project/pstoedit/pstoedit/3.74
--->  Attempting to fetch pstoedit-3.74.tar.gz from https://ayera.dl.sourceforge.net/project/pstoedit/pstoedit/3.74
--->  Verifying checksums for pstoedit                                          
--->  Extracting pstoedit
--->  Applying patches to pstoedit
--->  Configuring pstoedit
--->  Building pstoedit
Error: Failed to build pstoedit: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_pstoedit/pstoedit/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
MacBook-Pro:lda2vec davidlaxer$ vi /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_pstoedit/pstoedit/main.log

Attachments (1)

main.log (63.7 KB) - added by dbl001 (dbl) 22 months ago.

Download all attachments as: .zip

Change History (14)

Changed 22 months ago by dbl001 (dbl)

Attachment: main.log added

comment:1 Changed 22 months ago by dyne2meter

This also happened for me, OS X 10.11.6.

comment:2 Changed 22 months ago by ryandesign (Ryan Schmidt)

Keywords: pstoedit removed
Summary: Error: Failed to build pstoedit: command execution failedpstoedit @3.74: error: call to 'abs' is ambiguous

We started to see such errors with lots of projects some time ago, after a new version of Xcode was released:

query:summary=~call+to+%27abs%27+is+ambiguous

My understanding is that this is a mistake in the code, so I recommend notifying the developers of pstoedit so they can fix it.

Surprisingly, pstoedit built successfully on Mojave and High Sierra, suggesting that maybe the developers of clang changed their minds about this condition and no longer consider it an error. Still, since some versions of clang do consider it an error, the developers of pstoedit should probably account for it.

comment:3 Changed 22 months ago by tehcog (tehcog)

Cc: tehcog added

comment:4 Changed 22 months ago by tehcog (tehcog)

Mavericks also, so much older version of Xcode...

Last edited 22 months ago by tehcog (tehcog) (previous) (diff)

comment:5 Changed 22 months ago by dyne2meter

Well, octave depends on pstoedit. I thought it was a good idea to put all the pstoedit functionality into a separate port so that it could be updated separately, since it is updated less frequently than octave is, or at least that seemed to be the case a year or so ago when all that started. I'm not sure how to inform the pstoedit development team exactly what the problem is and why they should care, but I can certainly try.

comment:6 Changed 22 months ago by tehcog (tehcog)

Thanks

comment:7 Changed 22 months ago by dyne2meter

The developer, Wolfgang Glunz (glunz35@…), has replied. He asks that we try the following:

Insert at top of dxfacad.h:

#include <cmath>

Then: replace the abs in line 248 with std::abs

Other stuff I read online in reference to this ambiguity indicated something along these lines.

Glunz adds that if this works, he will apply this change in the next version. That's all I have for now.

Someone wiser than I will know the ins and outs from here. Is there some sort of patches port for the legacy systems?

Should I continue to correspond with him pending the outcome of this change?

Last edited 22 months ago by dyne2meter (previous) (diff)

comment:8 in reply to:  7 Changed 22 months ago by fgdb (Fico)

Replying to dyne2meter:

The developer, Wolfgang Glunz (glunz35@…), has replied. He asks that we try the following:

Insert at top of dxfacad.h:

#include <cmath>

Then: replace the abs in line 248 with std::abs

Other stuff I read online in reference to this ambiguity indicated something along these lines.

Glunz adds that if this works, he will apply this change in the next version. That's all I have for now.

Someone wiser than I will know the ins and outs from here. Is there some sort of patches port for the legacy systems?

Should I continue to correspond with him pending the outcome of this change?

I confirm: by applying the suggested changes to dxfacad.h, pstoedit does compile.

However, at this moment I'm unable to provide full runtime testing.

comment:9 Changed 22 months ago by Blokkendoos (Johan)

Cc: Blokkendoos added

comment:10 Changed 22 months ago by dliessi (Davide Liessi)

Cc: dliessi added

comment:11 Changed 22 months ago by bpdegnan (Brian Degnan)

I was able to compile and test it on MacOS 10.11.6 (Apple LLVM version 8.0.0 (clang-800.0.38)) Seems like that simple fix is all it took.

comment:12 Changed 21 months ago by dyne2meter

This port is listed as having no maintainer. When I get back from holidays, I may take the plunge, otherwise this defect is likely to languish indefinitely.

comment:13 Changed 21 months ago by dliessi (Davide Liessi)

Owner: set to dliessi
Resolution: fixed
Status: newclosed

In f692476264263c5ad94eab309204028a65874a5e/macports-ports (master):

pstoedit: use abs from cmath

Closes: #58602

Note: See TracTickets for help on using tickets.