#58674 closed update (fixed)

commons-validator: update to 1.6

Reported by: chrstphrchvz (Christopher Chavez) Owned by: chrstphrchvz (Christopher Chavez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: commons-validator

Description (last modified by chrstphrchvz (Christopher Chavez))

commons-validator 1.6 was released in 2017; current version in MacPorts is 1.3.1, released 2006; port has been outdated since the release of 1.4.0 in 2012.

Is this port still desirable? Its only dependent appears to be struts, which is outdated (#58673) This port has no dependents.

Note that the dependencies are different for the newer releases of commons-validator (at least one of the old dependencies is EOL: jakarta-oro, #53458).

Change History (2)

comment:1 Changed 15 months ago by chrstphrchvz (Christopher Chavez)

Description: modified (diff)

struts was removed ([6f496bc8d7/macports-ports]), so this port has no dependents.

There is already difficulty installing this port due to dependency on commons-collections, which JDK 8 and higher are unable to compile: #53939

Last edited 15 months ago by chrstphrchvz (Christopher Chavez) (previous) (diff)

comment:2 Changed 12 months ago by chrstphrchvz (Christopher Chavez)

Owner: set to chrstphrchvz
Resolution: fixed
Status: newclosed

In b508630a9b42cc954fdb2ed1d29d4e1c7db4598f/macports-ports (master):

commons-validator: delete port

Port is outdated, and was mainly needed by tomcat5, tomcat6, and struts,
which have been deleted. Depends on broken port commons-collections.

Closes: #58674

Note: See TracTickets for help on using tickets.