Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#58793 closed defect (duplicate)

cctools breaks when it’s selected llvm variant is deactivated

Reported by: weissman (Daniel Weissman) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: cctools

Description

I tried to upgrade my port of poppler, but the build failed. I cleaned it, uninstalled it, and tried to reinstall, but the build failed again. The problem seems to be that it's looking for the wrong llvm version -- from the attached log:

:info:build fatal error: otool: can't find or exec: /opt/local/bin/llvm-objdump-mp-4.0 (No such file or directory)

I have llvm version 8.0 installed instead, including opt/local/bin/llvm-objdump-mp-8.0. Any suggestions on how I should proceed?

Attachments (1)

main.log (710.2 KB) - added by weissman (Daniel Weissman) 15 months ago.
installation log

Download all attachments as: .zip

Change History (10)

Changed 15 months ago by weissman (Daniel Weissman)

Attachment: main.log added

installation log

comment:1 Changed 15 months ago by kencu (Ken)

Activate or install llvm 4.0 and you should be back in business.

comment:2 Changed 15 months ago by mouse07410 (Mouse)

Any reason why poppler shouldn't build and work with llvm-8.0?

comment:3 Changed 15 months ago by kencu (Ken)

The issue here is that cctools was installed with the llvm-4.0 variant, but then llvm-4.0 was replaced by llvm 8.0.

So, either get llvm 4.0 back (easy to explain) or reinstall cctools with the llvm 8.0 variant (better, but a bit harder to explain).

Either would fix this issue. Has nothing to do with poppler, per se.

comment:4 Changed 15 months ago by kencu (Ken)

Cc: devans@… removed
Owner: set to jeremyhu
Port: cctools added; poppler removed
Status: newassigned
Summary: poppler @0.79.0 build failurecctools breaks when it’s selected llvm variant is deactivated

comment:5 Changed 15 months ago by jmroot (Joshua Root)

I think this is essentially a duplicate of #58735? As I said in that ticket, rev bumping cctools would fix it.

comment:6 Changed 15 months ago by kencu (Ken)

you're right; I thought we had closed that other ticket, but we did not.

comment:7 Changed 15 months ago by kencu (Ken)

Resolution: duplicate
Status: assignedclosed

comment:8 Changed 15 months ago by mouse07410 (Mouse)

So, either get llvm 4.0 back (easy to explain) or reinstall cctools with the llvm 8.0 variant (better, but a bit harder to explain).

Let me try. ;-) The best solution is re-installing cctools specifying llvm-8, like this (given the current Macports defaults):

$ sudo port uninstall cctools
$ sudo port install cctools

or sudo port upgrade -n --enforce-variants cctools +llvm80

@kencu, one of the above is likely to be correct. I just don't remember which one I used.

comment:9 in reply to:  5 Changed 15 months ago by weissman (Daniel Weissman)

Installing cctools +llvm80 fixed it -- thank you! I had missed #58735.

Note: See TracTickets for help on using tickets.